summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-03-28 10:37:30 +0200
committerPacho Ramos <pacho@gentoo.org>2021-03-28 10:37:30 +0200
commita127132c3526bcb8b2b551d29af82a411a8b4dde (patch)
tree21901445bbf301274065414083ccbfa6c3af33d1 /gnome-extra
parentx11-themes/adwaita-qt: Bump to 1.2.1 (diff)
downloadgentoo-a127132c3526bcb8b2b551d29af82a411a8b4dde.tar.gz
gentoo-a127132c3526bcb8b2b551d29af82a411a8b4dde.tar.bz2
gentoo-a127132c3526bcb8b2b551d29af82a411a8b4dde.zip
gnome-extra/gnome-shell-extension-applications-overview-tooltip: Bump to v11
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-11.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest
index d162dd4fc18b..091f2fc77a6a 100644
--- a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest
+++ b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest
@@ -1,2 +1,3 @@
DIST gnome-shell-extension-applications-overview-tooltip-10.tar.gz 81397 BLAKE2B a9c838eb66ae49a3a195d8ce6e17fd971fb0dec00f62a2a7380fc973c9ba129611a93b904c658318e0bc80fb26ff9d65100cccd29f7f172dbef0f406bacefd14 SHA512 28bcc52b38d36e0897c949ba0eef11a94fce2e022ca3d398208221476b63b39281db9870d0c26a4bdffc07bb82e9d8942fd98820c78c6a4afe6d52eb5758e1c1
+DIST gnome-shell-extension-applications-overview-tooltip-11.tar.gz 81717 BLAKE2B bbafaa58bd9b7b56c5cc12c953922d40c1901fe78491d5ea344ab6f3dda65e51c02851b2106ef271d662be365722ca35f61a836f509bc1e6a4e6c03ecf1de3eb SHA512 c108b8bbf09793a18eced02e7fc5a68f1d71b9b31f0480b9346bf9b44507fedf85e6c1e640fa7d282ea69b63ad056116acecb494beb5c18b784b00348e485f00
DIST gnome-shell-extension-applications-overview-tooltip-9.tar.gz 81415 BLAKE2B 518352e80b5a3c6f8a2ff05e692178436625ea533e10a2afde82e73b6216f82dc29119c0e0a204ac8f1619de9409c47105107b94e3c4d1027c852b255eeb27ab SHA512 b8a2879f303a76e68eb5921005453e3fb73d966f1ed3f5978d9d210f447d8f780b5d9fa359aaa411f7ed8cecf72171dfcaa8da8515fd620193676b1b63742636
diff --git a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-11.ebuild b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-11.ebuild
new file mode 100644
index 000000000000..0ff533431bed
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-11.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2-utils
+
+# Workaround until https://bugzilla.gnome.org/show_bug.cgi?id=663725 is fixed
+DESCRIPTION="Show tooltip with full name and description"
+HOMEPAGE="https://github.com/RaphaelRochet/applications-overview-tooltip"
+SRC_URI="https://github.com/RaphaelRochet/applications-overview-tooltip/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# https://github.com/RaphaelRochet/applications-overview-tooltip/issues/7
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-3.38
+"
+DEPEND=""
+BDEPEND=""
+
+S="${WORKDIR}/${P/gnome-shell-extension-}"
+
+src_install() {
+ einstalldocs
+ insinto /usr/share/glib-2.0/schemas
+ doins schemas/*.xml
+ rm -rf README.md schemas || die
+ insinto /usr/share/gnome-shell/extensions/applications-overview-tooltip@RaphaelRochet
+ doins -r *
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}