summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-22 22:44:42 -0700
committerMatt Turner <mattst88@gentoo.org>2022-03-22 23:14:35 -0700
commita6982d6e1c565818c8b51232ac21d7511e060050 (patch)
treed5e46ef993a9e6b3bd3605d0aaacd1d84da3e818 /gnome-extra
parentnet-misc/mobile-broadband-provider-info: Version bump to 20220315 (diff)
downloadgentoo-a6982d6e1c565818c8b51232ac21d7511e060050.tar.gz
gentoo-a6982d6e1c565818c8b51232ac21d7511e060050.tar.bz2
gentoo-a6982d6e1c565818c8b51232ac21d7511e060050.zip
gnome-extra/nm-applet: Version bump to 1.26.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/nm-applet/Manifest1
-rw-r--r--gnome-extra/nm-applet/nm-applet-1.26.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/gnome-extra/nm-applet/Manifest b/gnome-extra/nm-applet/Manifest
index 02e16799f7ce..719ee1a15d3e 100644
--- a/gnome-extra/nm-applet/Manifest
+++ b/gnome-extra/nm-applet/Manifest
@@ -1 +1,2 @@
DIST network-manager-applet-1.24.0.tar.xz 1903280 BLAKE2B a969ab18e2d2d85d378d9964e635281cfcd4bc46e0542ec94e187cbe7e740c5fad8e10b3d7d3ae3b85352ba5368787650f933b89740d05ee06d78057e1c31712 SHA512 7b91bd54d53b1b485bc5e401f83c683804175900557a7a4bc40a3f759fa9d4ca1c42b193bcd56a39a8cb79ec5b0c6f7cbeccfc08200099c08d933650c92faecb
+DIST network-manager-applet-1.26.0.tar.xz 1971896 BLAKE2B ab87b0e5f8b1c293ac3f2e36c8f834e645fb647e46ce1bf22ac94ed33e6f2f7f8aca5ed43ed46029a281545595978c145773102f06de9b42e579efb8d3e631c3 SHA512 ae3c4f8e55a2cd13093161e1e28873d3cda1c531168ee18115f3f710816f1bdfcf669cd2f796bd38f226d3f6be76407fccbcb19cf9c994b99969b688397b2c71
diff --git a/gnome-extra/nm-applet/nm-applet-1.26.0.ebuild b/gnome-extra/nm-applet/nm-applet-1.26.0.ebuild
new file mode 100644
index 000000000000..e49a7e278547
--- /dev/null
+++ b/gnome-extra/nm-applet/nm-applet-1.26.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+GNOME_ORG_MODULE="network-manager-applet"
+
+inherit gnome.org meson xdg
+
+DESCRIPTION="NetworkManager connection editor and applet"
+HOMEPAGE="https://wiki.gnome.org/Projects/NetworkManager"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="appindicator modemmanager selinux teamd"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ >=app-crypt/libsecret-0.18
+ >=net-libs/libnma-1.8.27
+ >=x11-libs/gtk+-3.10:3
+ >=dev-libs/libgudev-147:=
+ >=x11-libs/libnotify-0.7.0
+ >=net-misc/networkmanager-1.16:=[modemmanager?,teamd?]
+ appindicator? (
+ dev-libs/libappindicator:3
+ >=dev-libs/libdbusmenu-16.04.0
+ )
+ modemmanager? ( net-misc/modemmanager )
+ selinux? ( sys-libs/libselinux )
+ teamd? ( >=dev-libs/jansson-2.7:= )
+
+ virtual/freedesktop-icon-theme
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dappindicator=$(usex appindicator ubuntu no)
+ $(meson_use modemmanager wwan)
+ $(meson_use selinux)
+ $(meson_use teamd team)
+ -Dmore_asserts=0
+ -Dld_gc=false
+ )
+ meson_src_configure
+}