summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-09-08 01:08:05 +0300
committerMart Raudsepp <leio@gentoo.org>2019-09-08 01:08:55 +0300
commitadfa93a4401ce8e3a20a6527c0d28214d85348b1 (patch)
tree9e48dc2c267c8667b533551cc70305343f77f532 /gnome-extra
parentmail-client/evolution: bump to 3.32.4 (diff)
downloadgentoo-adfa93a4401ce8e3a20a6527c0d28214d85348b1.tar.gz
gentoo-adfa93a4401ce8e3a20a6527c0d28214d85348b1.tar.bz2
gentoo-adfa93a4401ce8e3a20a6527c0d28214d85348b1.zip
gnome-extra/evolution-ews: bump to 3.32.2
Package-Manager: Portage-2.3.69, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/evolution-ews/Manifest1
-rw-r--r--gnome-extra/evolution-ews/evolution-ews-3.32.2.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/gnome-extra/evolution-ews/Manifest b/gnome-extra/evolution-ews/Manifest
index 5e43bcb9f648..88654c07c40c 100644
--- a/gnome-extra/evolution-ews/Manifest
+++ b/gnome-extra/evolution-ews/Manifest
@@ -1,2 +1,3 @@
DIST evolution-ews-3.30.5-certificate-validation.patch.xz 6928 BLAKE2B eb1f070797231f14cc71cce2f19a0dc925edc0f67eca9267568c835e878d9f1567aaad7dd8a14c88abb047af8db8220239c78d62387329c9d38e5c5eda21822b SHA512 2d4fa5f9c24bf92ab4e5105cc5d265907e8af760d7c969ffdf74d090795948e1f9e0e84f5d051c2a6c4324ed49cc2c23f23ebdccf67fa8baab965c612ad807e6
DIST evolution-ews-3.30.5.tar.xz 525252 BLAKE2B 510666cdf6bdb95e73799256daa9b4c753ed70de71798d3acb73eb55c30158a7b6b56fe7617150ec0a1f5ce20676da8a3ab4608fca06f009ea16fbc234770736 SHA512 6b17fd73b461e0ddd725ee87c854fca45fbc14f10922a60aff5a9a25b56728f1f16a0d3196b4bc3cba83e75655c15244c3bf2442fa17449c7466ab95371e93d7
+DIST evolution-ews-3.32.2.tar.xz 534056 BLAKE2B 2f935910cba44d69b2d8bcc3021709502c1a129ef29d18a847bccd14837d0c18c9700a97f978decb36f9c28242df81a9021dfc536e31f3d8f7793a0dc4c6b680 SHA512 5696ea660d0b52c0083664ad203eaed372fb9653399152ccbca0f6360a3e0c4503b5dacf4f9bf5650b1b64696c0fe06e2383bb408bed604ea0312660b4639388
diff --git a/gnome-extra/evolution-ews/evolution-ews-3.32.2.ebuild b/gnome-extra/evolution-ews/evolution-ews-3.32.2.ebuild
new file mode 100644
index 000000000000..403bd52ea196
--- /dev/null
+++ b/gnome-extra/evolution-ews/evolution-ews-3.32.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils gnome2
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange Web Services"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.46:2
+ dev-libs/libical:0=
+ >=dev-libs/libmspack-0.4
+ dev-libs/libxml2:2
+ >=gnome-extra/evolution-data-server-${PV}-r1:0=
+ >=mail-client/evolution-${PV}:2.0
+ >=net-libs/libsoup-2.58:2.4
+ >=x11-libs/gtk+-3.10:3
+"
+DEPEND="${RDEPEND}
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/intltool-0.35.5
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+ test? ( net-libs/uhttpmock )
+"
+
+# Unittests fail to find libevolution-ews.so
+RESTRICT="test !test? ( test )"
+
+# global scope PATCHES or DOCS array mustn't be used due to double default_src_prepare
+# call; if needed, set them after cmake-utils_src_prepare call, if that works
+src_prepare() {
+ cmake-utils_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_MSPACK=ON
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_test() {
+ cmake-utils_src_test
+}
+
+src_install() {
+ cmake-utils_src_install
+}