summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-08-09 10:09:52 +0300
committerMart Raudsepp <leio@gentoo.org>2020-08-09 10:22:13 +0300
commitb66567dbfcfd9f2153db0c6514c5b1abab49ecb1 (patch)
tree482bbe1e5fc4168ee2f15af4fb59e669aa125ef9 /gnome-extra
parentmail-client/evolution: bump to 3.36.5 (diff)
downloadgentoo-b66567dbfcfd9f2153db0c6514c5b1abab49ecb1.tar.gz
gentoo-b66567dbfcfd9f2153db0c6514c5b1abab49ecb1.tar.bz2
gentoo-b66567dbfcfd9f2153db0c6514c5b1abab49ecb1.zip
gnome-extra/evolution-ews: bump to 3.36.5
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/evolution-ews/Manifest1
-rw-r--r--gnome-extra/evolution-ews/evolution-ews-3.36.5.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/gnome-extra/evolution-ews/Manifest b/gnome-extra/evolution-ews/Manifest
index 9cdf966dccb8..674a8131c76c 100644
--- a/gnome-extra/evolution-ews/Manifest
+++ b/gnome-extra/evolution-ews/Manifest
@@ -1 +1,2 @@
DIST evolution-ews-3.36.4.tar.xz 558764 BLAKE2B 04823d04577b9d5597edf4b534d13f3bd82ac345bcfc5600a28f104917bb3f26513ae2fd7fad7b650728336fdbfac7cd94f4dd4b7cc77789570bf54def38feb0 SHA512 3b0ff6fec5dc857e49386adec9cf4ed962fc1bc95c23cca3852bbb4a63a4a3ae737511964adbccbbc52c409749dbdc71969231d4003ed284f12d655046f4ecdd
+DIST evolution-ews-3.36.5.tar.xz 558900 BLAKE2B 059a72b087287d0e553e085dc764a928d838bc8bd011c16b00f240b29d12bc7cfda98d33f8dc102866f5747313975e32506dc016435342bdb6c35f7d73749b52 SHA512 9cc40ae5d56bc86a8aa4e7aaa36fa10b0841278dd1edb075155bfe3666da4051e4fc4843398f74d00d77f550aaeb93bf576007828da4c574a17d4f17c41bfb7f
diff --git a/gnome-extra/evolution-ews/evolution-ews-3.36.5.ebuild b/gnome-extra/evolution-ews/evolution-ews-3.36.5.ebuild
new file mode 100644
index 000000000000..b3b87637eb31
--- /dev/null
+++ b/gnome-extra/evolution-ews/evolution-ews-3.36.5.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils gnome2
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange Web Services"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# libical-glib currently (2020-02-29) oddly behind USE=introspection
+RDEPEND="
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.46:2
+ >=dev-libs/libical-3.0.5:0=[introspection(-)]
+ >=dev-libs/libmspack-0.4
+ dev-libs/libxml2:2
+ >=gnome-extra/evolution-data-server-${PV}:0=
+ >=mail-client/evolution-${PV}:2.0
+ >=net-libs/libsoup-2.58:2.4
+ >=x11-libs/gtk+-3.10:3
+"
+DEPEND="${RDEPEND}
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/intltool-0.35.5
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+ test? ( net-libs/uhttpmock )
+"
+
+# Unittests fail to find libevolution-ews.so
+RESTRICT="test !test? ( test )"
+
+# global scope PATCHES or DOCS array mustn't be used due to double default_src_prepare
+# call; if needed, set them after cmake-utils_src_prepare call, if that works
+src_prepare() {
+ cmake-utils_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_MSPACK=ON
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_test() {
+ cmake-utils_src_test
+}
+
+src_install() {
+ cmake-utils_src_install
+}