summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-11-15 11:11:27 +0100
committerPacho Ramos <pacho@gentoo.org>2015-11-15 11:30:17 +0100
commitcc2c8b60c08654146db37580549b6a5c55e93cf3 (patch)
tree51e36c6860330196202e3cfa1b1ff1ba7ef2fc0a /gnome-extra
parentgnome-extra/sushi: Drop old (diff)
downloadgentoo-cc2c8b60c08654146db37580549b6a5c55e93cf3.tar.gz
gentoo-cc2c8b60c08654146db37580549b6a5c55e93cf3.tar.bz2
gentoo-cc2c8b60c08654146db37580549b6a5c55e93cf3.zip
gnome-extra/yelp: Version bump
Package-Manager: portage-2.2.24
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/yelp/Manifest1
-rw-r--r--gnome-extra/yelp/yelp-3.18.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/gnome-extra/yelp/Manifest b/gnome-extra/yelp/Manifest
index 098b6172d5cf..19425384d218 100644
--- a/gnome-extra/yelp/Manifest
+++ b/gnome-extra/yelp/Manifest
@@ -1 +1,2 @@
DIST yelp-3.16.1.tar.xz 1416752 SHA256 60810b8ddf5d2bf525a70a80a982af5053db061e0d823ed883d3671d9a5267ca SHA512 bfbce5c86dd6ee6d95cd4fc14acf8285616f4aef52b14d0b68f6844fbdad17631c84c2bc029e7ee0599055c00dd8599bf20341686290060b8c27ffddc2265103 WHIRLPOOL bab7e1f4297bcef0896a497c3d2a8d016405a77f77ae9810c80425dfb7234f018e6eb4688f2c408e9a71408684d107fef4de113bb007a0fe7f0850ba4d6a6e87
+DIST yelp-3.18.1.tar.xz 1386044 SHA256 ba3a4eb4717c0ecf4a2e40eff0963fcd12c700c4fb80b83ecaad8b7032256880 SHA512 ebff55bb3eb0caad208abfad3d83fa996d63bb97647ff446d25590b5c84d341161f3fdb9987353bd55e73ef2634baa692928fbc21b4ed16b6070500228fc2425 WHIRLPOOL 2f7479641bea73e248508a51e056eb33c9e3c30994017b8c17dfb0153a71f6174152aa8c05dd76fbb4bcc06b72a92bbc1fc46a7c10b19c3b5a62d597390aa3f5
diff --git a/gnome-extra/yelp/yelp-3.18.1.ebuild b/gnome-extra/yelp/yelp-3.18.1.ebuild
new file mode 100644
index 000000000000..99d4d1d55049
--- /dev/null
+++ b/gnome-extra/yelp/yelp-3.18.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Help browser for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Yelp"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+
+RDEPEND="
+ app-arch/bzip2:=
+ >=app-arch/xz-utils-4.9:=
+ dev-db/sqlite:3=
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/libxml2-2.6.5:2
+ >=dev-libs/libxslt-1.1.4
+ >=gnome-extra/yelp-xsl-3.12
+ >=net-libs/webkit-gtk-2.7.2:4
+ >=x11-libs/gtk+-3.13.3:3
+ x11-themes/gnome-icon-theme-symbolic
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.13
+ >=dev-util/intltool-0.41.0
+ dev-util/itstool
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Fix compatibility with Gentoo's sys-apps/man
+ # https://bugzilla.gnome.org/show_bug.cgi?id=648854
+ epatch "${FILESDIR}"/${PN}-3.16.0-man-compatibility.patch
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --enable-bz2 \
+ --enable-lzma
+}