summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew S. Turnbull <sparky@bluefang-logic.com>2023-05-07 02:43:16 -0400
committerSam James <sam@gentoo.org>2023-05-07 23:13:36 +0100
commitce174ef14ad2858e8f33119de5cbe49627deee1b (patch)
tree387fe97c9c2754ae969c4280065b14c7ffddcff2 /gnome-extra
parentx11-wm/muffin: add 5.6.4 (diff)
downloadgentoo-ce174ef14ad2858e8f33119de5cbe49627deee1b.tar.gz
gentoo-ce174ef14ad2858e8f33119de5cbe49627deee1b.tar.bz2
gentoo-ce174ef14ad2858e8f33119de5cbe49627deee1b.zip
gnome-extra/nemo: add 5.6.5
Clean-up some qa-vdb warnings. Signed-off-by: Matthew S. Turnbull <sparky@bluefang-logic.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/nemo/Manifest1
-rw-r--r--gnome-extra/nemo/nemo-5.6.5.ebuild131
2 files changed, 132 insertions, 0 deletions
diff --git a/gnome-extra/nemo/Manifest b/gnome-extra/nemo/Manifest
index c99d16ec27e1..6dc5cd1a5d3b 100644
--- a/gnome-extra/nemo/Manifest
+++ b/gnome-extra/nemo/Manifest
@@ -1,2 +1,3 @@
DIST nemo-5.2.4.tar.gz 1492077 BLAKE2B dc6efb24921d5408938ff5b8660653789a77d6607e2e023d73eb5722a0a8bc75cd22d1241f5e852d0429d05f6ec4fd1abb798b8be1ecf513eeed108a256e506c SHA512 0aa3f7e0c2bdb9d7f1874c17caea0e4a3da062fc243de1f1657bdb83090a1afb099baa404f211092f83cf6852c423b244482faf0ad6beaaddc072cbce17cc6d4
DIST nemo-5.6.1.tar.gz 1496434 BLAKE2B 74c6745640a03c6fc61834f07d823221300d87c772cdb5dfe2c211c01a4808e76c50e573d3d481f72a9be820c849ffb0725df8bfbfff6c61b030be673030b751 SHA512 7880c034da893f7f0fb696a7ca885fd3b40cfde3a39f16cdc5963ffc73a55665e1aad37a62f9d06463cd27753bbe9420c760b733d9bc5f02e3e77df892f19eba
+DIST nemo-5.6.5.tar.gz 1498469 BLAKE2B 1ead71e79170e977e21dd631f7875198b3aa411689bd59b9c64b50a3c3b02a396f2b1cbc1e1420bf242004a6a724b8498e7e0cdd2b48b9d5e54ed97d21331cba SHA512 b37181e419d5a9427931d29f2addf9faebca7d74d8b8337dc9cb62ebc3b8f8d9dcef978bc6fc9be65efc41bd2a153685849f10cac9e28ffb3ccb3a8dee5aa739
diff --git a/gnome-extra/nemo/nemo-5.6.5.ebuild b/gnome-extra/nemo/nemo-5.6.5.ebuild
new file mode 100644
index 000000000000..237d8d3be4f8
--- /dev/null
+++ b/gnome-extra/nemo/nemo-5.6.5.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit meson gnome2-utils python-single-r1 readme.gentoo-r1 virtualx xdg
+
+DESCRIPTION="A file manager for Cinnamon, forked from Nautilus"
+HOMEPAGE="https://projects.linuxmint.com/cinnamon/ https://github.com/linuxmint/nemo"
+SRC_URI="https://github.com/linuxmint/nemo/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+ LGPL-2+ LGPL-2.1+ FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="exif gtk-doc +nls selinux test xmp"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# https://github.com/linuxmint/nemo/issues/2501
+RESTRICT="test"
+
+COMMON_DEPEND="
+ ${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ >=dev-libs/glib-2.45.7:2[dbus]
+ >=dev-libs/gobject-introspection-0.9.12:=
+ >=dev-libs/libxml2-2.7.8:2
+ >=gnome-extra/cinnamon-desktop-5.6:0=
+ gnome-extra/libgsf:=
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.10.0:3[introspection]
+ x11-libs/libX11
+ >=x11-libs/pango-1.40.0
+ >=x11-libs/xapp-2.4.1
+
+ exif? ( >=media-libs/libexif-0.6.20 )
+ selinux? ( sys-libs/libselinux )
+ xmp? ( >=media-libs/exempi-2.2.0:= )
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ x11-themes/adwaita-icon-theme
+
+ nls? ( >=gnome-extra/cinnamon-translations-5.6 )
+"
+PDEPEND="
+ >=gnome-base/gvfs-0.1.2
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ >=dev-util/gdbus-codegen-2.31.0
+ >=dev-util/intltool-0.40.1
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ gtk-doc? ( dev-util/gtk-doc )
+"
+
+PATCHES=(
+ # Undo the switch to untex as it's not packaged.
+ "${FILESDIR}/${PN}-5.0.3-use-detex.patch"
+)
+
+DISABLE_AUTOFORMATTING="yes"
+FORCE_PRINT_ELOG="yes"
+DOC_CONTENTS="
+${PN} functionality can be extended by installing other packages.
+
+sys-apps/gnome-disk-utility - Mount archive files
+gnome-extra/nemo-fileroller - Extract/Create archive files
+
+${PN} search capabilities can be extended through external
+helpers. Install any of the following packages to make
+their associated file types searchable.
+
+epub - app-arch/unzip and app-text/html2text
+Image metadata - media-gfx/exif
+MP3 tags - media-sound/id3
+Microsoft Office .doc - app-text/catdoc
+Microsoft Office .xls - dev-python/xlrd
+OpenDocument/LibreOffice - app-text/odt2txt or app-office/unoconv
+PDF - app-text/poppler[utils]
+PostScript - app-text/ghostscript-gpl
+TeX - app-text/texlive-core
+"
+
+src_prepare() {
+ default
+ python_fix_shebang files/usr/share/nemo/actions install-scripts
+}
+
+src_configure() {
+ # tracker: only supports unmaintained tracker-2, not >=tracker-3.
+ local emesonargs=(
+ $(meson_use exif)
+ $(meson_use xmp)
+ $(meson_use selinux)
+ $(meson_use gtk-doc gtk_doc)
+
+ -Dtracker=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}