summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-04-02 17:00:57 -0700
committerMatt Turner <mattst88@gentoo.org>2022-04-02 17:03:30 -0700
commitd1e6cc04a72d595782a1cf4f6719688246229e0f (patch)
treec241bd0392047c3de9624168ff63d2a629b55638 /gnome-extra
parentapp-editors/gedit: Version bump to 42.0 (diff)
downloadgentoo-d1e6cc04a72d595782a1cf4f6719688246229e0f.tar.gz
gentoo-d1e6cc04a72d595782a1cf4f6719688246229e0f.tar.bz2
gentoo-d1e6cc04a72d595782a1cf4f6719688246229e0f.zip
gnome-extra/zenity: Version bump to 3.42.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/zenity/Manifest1
-rw-r--r--gnome-extra/zenity/zenity-3.42.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/gnome-extra/zenity/Manifest b/gnome-extra/zenity/Manifest
index 02144e07c866..b84aaccea570 100644
--- a/gnome-extra/zenity/Manifest
+++ b/gnome-extra/zenity/Manifest
@@ -1 +1,2 @@
DIST zenity-3.41.0.tar.xz 3093244 BLAKE2B 582a2e935331120c47ef997d100c28943694a9b8b35c70673c8dca6e129bf39d9a32c92cf6504602513ad6eb223239be584c56ef44fe609f8af320f27713ca4a SHA512 b198ae68fda77f74c9f6deba683759612067c4ee28551a667c96500296db89313f3f2330fcaa53b6e4840ee3367d438e766be8ba7c006952872aebe93684b307
+DIST zenity-3.42.0.tar.xz 3091448 BLAKE2B 0a2f595164f5f9e8ebfa800855b15b116ab453435a2a1287ba7c85698d391dfecce3c8e2f8237ce73403ce7187a340ed5353e4ff283b05a0ecdcdc55f950f526 SHA512 a17b7ee46f480ca3e3804d301d1a499393aa10aee62d96d5087841ca8951a46f2b51e8355dd63b81b078efd69a11d57ed4fa187052d98880b12e56fd11e53ddb
diff --git a/gnome-extra/zenity/zenity-3.42.0.ebuild b/gnome-extra/zenity/zenity-3.42.0.ebuild
new file mode 100644
index 000000000000..e81d45b27ae7
--- /dev/null
+++ b/gnome-extra/zenity/zenity-3.42.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Tool to display dialogs from the commandline and shell scripts"
+HOMEPAGE="https://wiki.gnome.org/Projects/Zenity"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="libnotify webkit"
+
+# TODO: X11 dependency is automagically enabled
+RDEPEND="
+ >=x11-libs/gtk+-3.16.0:3[X]
+ >=dev-libs/glib-2.43.4:2
+ libnotify? ( >=x11-libs/libnotify-0.6.1:= )
+ webkit? ( >=net-libs/webkit-gtk-2.8.1:4 )
+ x11-libs/libX11
+
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use libnotify)
+ $(meson_use webkit webkitgtk)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ # Not really needed and prevent us from needing perl
+ rm "${ED}/usr/bin/gdialog" || die "rm gdialog failed!"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}