summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-05-01 14:36:52 -0400
committerMatt Turner <mattst88@gentoo.org>2021-05-01 14:38:09 -0400
commitd5c22d88d094a118ffb97c91dec77a993bed031e (patch)
treea7b04a10c6371ace5c6777a2ea7145db6521f813 /gnome-extra
parentmedia-libs/libmatroska: fix lower bound on libebml (diff)
downloadgentoo-d5c22d88d094a118ffb97c91dec77a993bed031e.tar.gz
gentoo-d5c22d88d094a118ffb97c91dec77a993bed031e.tar.bz2
gentoo-d5c22d88d094a118ffb97c91dec77a993bed031e.zip
gnome-extra/gucharmap: Version bump to 13.0.7
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gucharmap/Manifest1
-rw-r--r--gnome-extra/gucharmap/gucharmap-13.0.7.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/gnome-extra/gucharmap/Manifest b/gnome-extra/gucharmap/Manifest
index 19b268bf2dd1..237856e3128f 100644
--- a/gnome-extra/gucharmap/Manifest
+++ b/gnome-extra/gucharmap/Manifest
@@ -1,2 +1,3 @@
DIST gucharmap-13.0.4.tar.gz 1900442 BLAKE2B 83925f04b23a5984e0180ae86d39842e419fe723604d3e93785241ed33ba56b80d68bfd8c99514ef542e515c78a0b64748781faa962d3a32e26746673ba4d2f0 SHA512 919f3298040962cf1b8636fe82a900e667d1f63c0f92c99b013d10cee7e7d5f074f3ffaa0ab8a8e3685b6764915a4e683e459fb680aeb65247c82c5a8a326bf9
+DIST gucharmap-13.0.7.tar.gz 1919890 BLAKE2B c90b09f2e52b27ea652a32c4a502a57767eb4f4cf5895a61f3a871f1f5fb81c27083938fc9394d2a74881bfd4c23fdf2cdbce2dc07a55cd3a7d9422e6da40ff9 SHA512 9ed3cea9560cfb53af61863b0811a4d62c347e404880154acd47c5e4148d5b5cf3c31a4ad3b8440081e0bc7b33666c6b0fed35c26f8ee9c0a1746d9ed61b19ca
DIST gucharmap-3.0.1.tar.bz2 3275481 BLAKE2B 80dde7791abdc72677add9c65c59f810e6c6952116b92db34059c4c40d2657246b17844c105e68f32c86294e9b4e71e9d48e6f0522855465734d7c24e8d17608 SHA512 4d8a2276b5cb1a0b0fadca2a8522755c5884985a12d5b19341b9cefcd7f749ec1286c0271419e38ec84be7edcfa1293e7f0263eb682c75387d692792de3e1fb1
diff --git a/gnome-extra/gucharmap/gucharmap-13.0.7.ebuild b/gnome-extra/gucharmap/gucharmap-13.0.7.ebuild
new file mode 100644
index 000000000000..efc145ee7aae
--- /dev/null
+++ b/gnome-extra/gucharmap/gucharmap-13.0.7.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+VALA_MIN_API_VERSION="0.26"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2-utils meson python-any-r1 vala xdg
+
+DESCRIPTION="Unicode character map viewer and library"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gucharmap"
+SRC_URI="https://gitlab.gnome.org/GNOME/${PN}/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="2.90"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+UNICODE_VERSION="13.0"
+
+IUSE="debug +introspection gtk-doc vala"
+REQUIRED_USE="vala? ( introspection )"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.19.8
+ gtk-doc? ( >=dev-util/gtk-doc-1 )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ $(vala_depend)"
+
+DEPEND="=app-i18n/unicode-data-${UNICODE_VERSION}*
+ >=dev-libs/glib-2.32:2
+ media-libs/freetype:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ >=x11-libs/pango-1.42.4-r2[introspection?]"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Ducd_path="${EPREFIX}/usr/share/unicode-data"
+ $(meson_use debug dbg)
+ $(meson_use gtk-doc docs)
+ $(meson_use introspection gir)
+ $(meson_use vala vapi)
+ )
+
+ meson_src_configure
+}
+
+src_test() {
+ meson_src_test
+}
+
+src_install() {
+ meson_src_install
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}