summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-08-23 16:02:05 +0300
committerMart Raudsepp <leio@gentoo.org>2020-08-23 16:02:32 +0300
commitf1c9ad5d70bb24b680ae91f4624c6a4722ef1c33 (patch)
tree6737c3aa43aa0dd583e64c69cab0732ff5c222e0 /gnome-extra
parentdev-java/jansi-native: updated homepage (diff)
downloadgentoo-f1c9ad5d70bb24b680ae91f4624c6a4722ef1c33.tar.gz
gentoo-f1c9ad5d70bb24b680ae91f4624c6a4722ef1c33.tar.bz2
gentoo-f1c9ad5d70bb24b680ae91f4624c6a4722ef1c33.zip
gnome-extra/gnome-system-monitor: bump to 3.36.1
Package-Manager: Portage-2.3.103, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-system-monitor/Manifest1
-rw-r--r--gnome-extra/gnome-system-monitor/gnome-system-monitor-3.36.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/gnome-extra/gnome-system-monitor/Manifest b/gnome-extra/gnome-system-monitor/Manifest
index e03093a09d65..d6ac4e776149 100644
--- a/gnome-extra/gnome-system-monitor/Manifest
+++ b/gnome-extra/gnome-system-monitor/Manifest
@@ -1 +1,2 @@
DIST gnome-system-monitor-3.32.1.tar.xz 676936 BLAKE2B 815c677f637919966868b454b47f9633f130155573f7895e0c70025a59978818051bf8d087761d15416ccb0470c7341365dd95fdeabcdd0711802f828eddfa37 SHA512 badfb98e4508096336bba4be79ce359cf4363649e97c1da534ed96a04de4bc57e12b84ed75bfa9086e00b61b6558ee4af25eee14f0d2636d3ee0b62956122cbd
+DIST gnome-system-monitor-3.36.1.tar.xz 705024 BLAKE2B 93f0bee524797ef76a8c90c9675d12fe4a9bc8c63a48fb86e3212f8be6bcebc26d5098f163b585748ac9832fc38f8591b8fa2509e1a541ed7637aa7c47ce0bca SHA512 52443c0dbcd4fffb7451f540f0e48088a956a4e176af708d198c6ac2054f454dbf910df21925daca484a30d6c1c3526ad634c38ab01f905a08a64b11938c0c2d
diff --git a/gnome-extra/gnome-system-monitor/gnome-system-monitor-3.36.1.ebuild b/gnome-extra/gnome-system-monitor/gnome-system-monitor-3.36.1.ebuild
new file mode 100644
index 000000000000..bede4e5d6400
--- /dev/null
+++ b/gnome-extra/gnome-system-monitor/gnome-system-monitor-3.36.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="The Gnome System Monitor"
+HOMEPAGE="https://help.gnome.org/users/gnome-system-monitor/stable/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="systemd X"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-cpp/glibmm-2.46:2
+ >=dev-libs/glib-2.56.0:2
+ >=x11-libs/gtk+-3.22:3[X(+)]
+ >=dev-cpp/gtkmm-3.3.18:3.0
+ >=gnome-base/libgtop-2.37.2:2=
+ >=gnome-base/librsvg-2.35:2
+ >=dev-libs/libxml2-2.0:2
+ X? ( >=x11-libs/libwnck-2.91.0:3 )
+ systemd? ( >=sys-apps/systemd-44:0= )
+"
+# eautoreconf requires gnome-base/gnome-common
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ >=sys-auth/polkit-0.114
+" # polkit needed at buildtime for ITS rules of policy files, first available in 0.114
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use X wnck)
+ $(meson_use systemd)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}