summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew S. Turnbull <sparky@bluefang-logic.com>2022-06-12 00:34:48 -0400
committerSam James <sam@gentoo.org>2022-10-13 00:04:52 +0100
commitf2ee9f1ac9700d70d45071d738156eb255fc01c9 (patch)
tree911640fed05f2f7accc8e0d678a5f370fe3d3670 /gnome-extra
parentgnome-extra/nemo-fileroller: Fix license declaration (diff)
downloadgentoo-f2ee9f1ac9700d70d45071d738156eb255fc01c9.tar.gz
gentoo-f2ee9f1ac9700d70d45071d738156eb255fc01c9.tar.bz2
gentoo-f2ee9f1ac9700d70d45071d738156eb255fc01c9.zip
gnome-extra/cjs: 5.4.1 version bump
Bug: https://bugs.gentoo.org/863197 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Matthew S. Turnbull <sparky@bluefang-logic.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/cjs/Manifest1
-rw-r--r--gnome-extra/cjs/cjs-5.4.1.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/gnome-extra/cjs/Manifest b/gnome-extra/cjs/Manifest
index f670bd811899..fab89bbba281 100644
--- a/gnome-extra/cjs/Manifest
+++ b/gnome-extra/cjs/Manifest
@@ -1 +1,2 @@
DIST cjs-5.2.0.tar.gz 601982 BLAKE2B 99fe183add425e5178863aa6b0af6aa0579de0dabee72ad9bcc86e2edf0ad13093ce659ac60ed365edb33ff1eb54d54766a7e0df1a65aa64b7da34e5559297c7 SHA512 0ce5cc07be036fa9af93c7d98a179881789f883578a2034c3c28255ef9da96d32b4203fc39311eaea0bdbe5148f13920d72dd24acb717c4e60302b390097a825
+DIST cjs-5.4.1.tar.gz 794618 BLAKE2B 6da2cbb5c000d5ef649f64136fd8e886b3b75df6433d62859b2e82080fd52247bd148d4092a92c4b3448718d66254dc0ab6affdf45e13a8eec07d40eef1933a5 SHA512 8fae67c90cfba012420a17d28b94694e86f962c03b69e90e4192d699ce38ca01c9a7be2febf95c16c27a556f101a581006206a9549259486be614cfbd400ef6b
diff --git a/gnome-extra/cjs/cjs-5.4.1.ebuild b/gnome-extra/cjs/cjs-5.4.1.ebuild
new file mode 100644
index 000000000000..fde49a84c379
--- /dev/null
+++ b/gnome-extra/cjs/cjs-5.4.1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit flag-o-matic meson pax-utils python-any-r1 virtualx
+
+DESCRIPTION="Linux Mint's fork of gjs for Cinnamon"
+HOMEPAGE="https://projects.linuxmint.com/cinnamon/ https://github.com/linuxmint/cjs"
+SRC_URI="https://github.com/linuxmint/cjs/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT || ( MPL-1.1 LGPL-2+ GPL-2+ )"
+SLOT="0"
+IUSE="+cairo examples readline sysprof test"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-lang/spidermonkey-78.2.0:78
+ >=dev-libs/glib-2.66.0:2
+ >=dev-libs/gobject-introspection-1.66.1:=
+ >=dev-libs/libffi-3.3:0=
+
+ cairo? ( x11-libs/cairo[glib,svg,X] )
+ readline? ( sys-libs/readline:0= )
+"
+DEPEND="
+ ${RDEPEND}
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4 )
+ test? (
+ sys-apps/dbus
+ x11-libs/gtk+:3[introspection]
+ )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ python_fix_shebang build
+}
+
+src_configure() {
+ append-cppflags -DG_DISABLE_CAST_CHECKS
+
+ # On musl, it's required that either gjs, pixman or gnome-shell to be built
+ # with a larger stack otherwise librsvg fails to render a particular SVG, as
+ # a result we fail to get gdm or gnome-shell running (greeted with a fail
+ # whale screen). The bug has been reported to librsvg. This is ideally just
+ # a temporary workaround until we understand what exactly needs a larger
+ # stack size, as it's not sufficient to do just librsvg.
+ #
+ # Please refer to:
+ # https://gitlab.gnome.org/GNOME/librsvg/-/issues/686
+ # https://gitlab.gnome.org/GNOME/librsvg/-/issues/874
+ #
+ # TODO: Find an actual fix instead of increasing the stack
+ use elibc_musl && append-ldflags -Wl,-z,stack-size=2097152
+
+ local emesonargs=(
+ $(meson_feature cairo)
+ $(meson_feature readline)
+ $(meson_feature sysprof profiler)
+ -Dinstalled_tests=false
+ $(meson_use !test skip_dbus_tests)
+ $(meson_use !test skip_gtk_tests)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+src_install() {
+ meson_src_install
+
+ if use examples; then
+ docinto examples
+ dodoc "${S}"/examples/*
+ fi
+
+ # Required for cjs-console to run correctly on PaX systems
+ pax-mark mr "${ED}/usr/bin/cjs-console"
+}