summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2021-11-06 23:32:58 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2021-11-06 23:35:00 +0100
commit2665e86cb449382a293ec9f8d58502679f1c6bf8 (patch)
tree5bf9cf78b06f4150a59f2c7789fc71ae2638367e /gnustep-apps/gemas/gemas-0.4-r1.ebuild
parentgnustep-apps/mpdcon: bump EAPI (diff)
downloadgentoo-2665e86cb449382a293ec9f8d58502679f1c6bf8.tar.gz
gentoo-2665e86cb449382a293ec9f8d58502679f1c6bf8.tar.bz2
gentoo-2665e86cb449382a293ec9f8d58502679f1c6bf8.zip
gnustep-apps/gemas: bump EAPI
Closes: https://bugs.gentoo.org/819999 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'gnustep-apps/gemas/gemas-0.4-r1.ebuild')
-rw-r--r--gnustep-apps/gemas/gemas-0.4-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnustep-apps/gemas/gemas-0.4-r1.ebuild b/gnustep-apps/gemas/gemas-0.4-r1.ebuild
new file mode 100644
index 000000000000..276c00b2e2fd
--- /dev/null
+++ b/gnustep-apps/gemas/gemas-0.4-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnustep-2
+
+MY_P=${P/g/G}
+DESCRIPTION="a simple code editor for GNUstep"
+HOMEPAGE="http://wiki.gnustep.org/index.php/Gemas.app"
+SRC_URI="mirror://nongnu/gnustep-nonfsf/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="projectcenter"
+
+DEPEND=">=gnustep-libs/highlighterkit-0.1.2
+ >=virtual/gnustep-back-0.22.0
+ projectcenter? ( gnustep-apps/projectcenter )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}"/${P}-bundle_makefile.patch )
+
+src_compile() {
+ gnustep-base_src_compile
+ if use projectcenter;
+ then
+ cd Bundle/Gemas || die
+ egnustep_make
+ fi
+}
+
+src_install() {
+ gnustep-base_src_install
+ if use projectcenter;
+ then
+ cd Bundle/Gemas || die
+ egnustep_install
+ fi
+}