summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-03-14 22:48:17 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2023-03-14 23:07:07 +0100
commit3e99d35addff4e2dc01486aee2a2b83b1156787d (patch)
tree6e201c35c2f92c68de8e261bcb9f871a26a29c80 /gnustep-base
parentnet-ftp/filezilla: add 3.63.2 (diff)
downloadgentoo-3e99d35addff4e2dc01486aee2a2b83b1156787d.tar.gz
gentoo-3e99d35addff4e2dc01486aee2a2b83b1156787d.tar.bz2
gentoo-3e99d35addff4e2dc01486aee2a2b83b1156787d.zip
gnustep-base/gnustep-base: add 1.29.0
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/gnustep-base/Manifest1
-rw-r--r--gnustep-base/gnustep-base/gnustep-base-1.29.0.ebuild71
-rw-r--r--gnustep-base/gnustep-base/metadata.xml21
3 files changed, 79 insertions, 14 deletions
diff --git a/gnustep-base/gnustep-base/Manifest b/gnustep-base/gnustep-base/Manifest
index 3c61aa7af1e9..3edc69493fb9 100644
--- a/gnustep-base/gnustep-base/Manifest
+++ b/gnustep-base/gnustep-base/Manifest
@@ -1,2 +1,3 @@
DIST gnustep-base-1.27.0.tar.gz 4141163 BLAKE2B b27f7086949bcd5e43b8d6337c4f03eb87447baacb23de75b7df0d2ba769ff3e8cadd7035e78b35c91ccca83151cbe4b61b339aa265dcb53847089849b615f8b SHA512 bbdf45379dbb684f6bdb507b645e0f611cefb05caadff1bf620c2e85f104396cf91782bcce05ff2173078603b76b8a0ba2ea3b71bc56a84c220310910dbcb705
DIST gnustep-base-1.28.0.tar.gz 4246622 BLAKE2B fdaa834ea3cb13b1d4717c2c7e6b59eff05d16e6a404ffed5f4ccfa2ee3db93ecfee5b95cc30be6a388f56fa28c67f1278ea298f222260dcc24abadaa1cb5e8f SHA512 e173fab28aa1b1df38de4216916db18934422a1d372b9fe6a68a6ff21b2ac0be38aa02631179a8ad62a4f2848080223f34771b364b1c0eebc96c84778677c50b
+DIST gnustep-base-1.29.0.tar.gz 3697809 BLAKE2B 9810e6220df79e75130e8e3cdda5d8c42e1e05351461920549e3163752eccc9fa4bb375c36a8b987877cf557140e961dda7e0fac1c1c9affdb38893567695ddf SHA512 19e876f32e4dce403beeb5522ae942c23cc2b947217a38fd045a495d81b3734a8cf160fb768d8cff64c45d8ae63ba422658f705519786016d3e8216efe0a044c
diff --git a/gnustep-base/gnustep-base/gnustep-base-1.29.0.ebuild b/gnustep-base/gnustep-base/gnustep-base-1.29.0.ebuild
new file mode 100644
index 000000000000..1b11436adb92
--- /dev/null
+++ b/gnustep-base/gnustep-base/gnustep-base-1.29.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnustep-base toolchain-funcs
+
+DESCRIPTION="A library of general-purpose, non-graphical Objective C objects"
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="https://github.com/gnustep/libs-base/releases/download/base-${PV//./_}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="+gnutls +iconv +icu +libffi zeroconf"
+
+RDEPEND="${GNUSTEP_CORE_DEPEND}
+ >=gnustep-base/gnustep-make-2.6.0
+ gnutls? ( net-libs/gnutls:= )
+ iconv? ( virtual/libiconv )
+ icu? ( >=dev-libs/icu-49.0:= )
+ !libffi? ( dev-libs/ffcall
+ gnustep-base/gnustep-make[-native-exceptions] )
+ libffi? ( dev-libs/libffi:= )
+ >=dev-libs/libxml2-2.6
+ >=dev-libs/libxslt-1.1
+ >=dev-libs/gmp-4.1:=
+ >=sys-libs/zlib-1.2
+ zeroconf? ( net-dns/avahi )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.26.0-no_compress_man.patch
+)
+
+src_configure() {
+ egnustep_env
+
+ local myconf
+ if use libffi ; then
+ myconf="--enable-libffi --disable-ffcall --with-ffi-include=$($(tc-getPKG_CONFIG) --variable=includedir libffi)"
+ else
+ myconf="--disable-libffi --enable-ffcall"
+ fi
+
+ myconf="$myconf $(use_enable gnutls tls)"
+ myconf="$myconf $(use_enable iconv)"
+ myconf="$myconf $(use_enable icu)"
+ myconf="$myconf $(use_enable zeroconf)"
+ myconf="$myconf --with-xml-prefix=${EPREFIX}/usr"
+ myconf="$myconf --with-gmp-include=${EPREFIX}/usr/include --with-gmp-library=${EPREFIX}/usr/lib"
+ myconf="$myconf --with-default-config=${EPREFIX}/etc/GNUstep/GNUstep.conf"
+
+ econf $myconf
+}
+
+src_install() {
+ # We need to set LD_LIBRARY_PATH because the doc generation program
+ # uses the gnustep-base libraries. Since egnustep_env "cleans the
+ # environment" including our LD_LIBRARY_PATH, we're left no choice
+ # but doing it like this.
+
+ egnustep_env
+ egnustep_install
+
+ if use doc ; then
+ export LD_LIBRARY_PATH="${S}/Source/obj:${LD_LIBRARY_PATH}"
+ egnustep_doc
+ fi
+ egnustep_install_config
+}
diff --git a/gnustep-base/gnustep-base/metadata.xml b/gnustep-base/gnustep-base/metadata.xml
index a4265795efea..c4f9cc0a5b48 100644
--- a/gnustep-base/gnustep-base/metadata.xml
+++ b/gnustep-base/gnustep-base/metadata.xml
@@ -1,18 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>gnustep@gentoo.org</email>
- <name>Gentoo GNUstep Project</name>
-</maintainer>
-<longdescription>
-The GNUstep Base Library is a library of general-purpose, non-graphical
-Objective C objects. For example, it includes classes for strings,
-object collections, byte streams, typed coders, invocations,
-notifications, notification dispatchers, moments in time, network ports,
-remote object messaging support (distributed objects), and event loops.
-
-It provides functionality that aims to implement the non-graphical
-portion of the OpenStep standard (the Foundation library).
-</longdescription>
+ <maintainer type="project">
+ <email>gnustep@gentoo.org</email>
+ <name>Gentoo GNUstep Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">gnustep/libs-base</remote-id>
+ </upstream>
</pkgmetadata>