summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2023-09-14 08:36:01 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-17 17:44:44 +0300
commit9c023971561c5e3da626e4b35e8116d0f5dbba61 (patch)
tree22e0bcaf7a4ac41c9af440571afaaaff5788c7fa /gnustep-libs/sqlclient/sqlclient-1.8.1-r1.ebuild
parentgnustep-libs/sqlclient: add github upstream metadata (diff)
downloadgentoo-9c023971561c5e3da626e4b35e8116d0f5dbba61.tar.gz
gentoo-9c023971561c5e3da626e4b35e8116d0f5dbba61.tar.bz2
gentoo-9c023971561c5e3da626e4b35e8116d0f5dbba61.zip
gnustep-libs/sqlclient: update EAPI 6 -> 8
Closes: https://bugs.gentoo.org/905681 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/32772 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'gnustep-libs/sqlclient/sqlclient-1.8.1-r1.ebuild')
-rw-r--r--gnustep-libs/sqlclient/sqlclient-1.8.1-r1.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/gnustep-libs/sqlclient/sqlclient-1.8.1-r1.ebuild b/gnustep-libs/sqlclient/sqlclient-1.8.1-r1.ebuild
deleted file mode 100644
index 1e588e7d224a..000000000000
--- a/gnustep-libs/sqlclient/sqlclient-1.8.1-r1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit java-pkg-opt-2 gnustep-2
-
-MY_P=${P/sqlc/SQLC}
-DESCRIPTION="GNUstep lightweight database abstraction layer"
-HOMEPAGE="http://wiki.gnustep.org/index.php/SQLClient"
-SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/libs/${MY_P}.tar.gz"
-
-KEYWORDS="~amd64 ~ppc ~x86"
-LICENSE="LGPL-3"
-SLOT="0"
-
-IUSE="java mysql postgres +sqlite"
-
-RDEPEND=">=gnustep-libs/performance-0.3.2
- mysql? ( dev-db/mysql-connector-c:= )
- postgres? ( dev-db/postgresql:= )
- sqlite? ( >=dev-db/sqlite-3 )"
-DEPEND="${RDEPEND}"
-
-REQUIRED_USE="|| ( java mysql postgres sqlite )"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- if ! use doc; then
- # Remove doc target
- sed -i -e '/documentation\.make/d' GNUmakefile \
- || die "doc sed failed"
- fi
-
- default
-}
-
-src_configure() {
- local myconf=""
- use java || myconf="${myconf} --disable-jdbc-bundle"
- use mysql || myconf="${myconf} --disable-mysql-bundle"
- use postgres || myconf="${myconf} --disable-postgres-bundle"
- use sqlite || myconf="${myconf} --disable-sqllite-bundle"
-
- egnustep_env
- econf ${myconf}
-}