summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-05-04 16:12:41 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-05-04 16:13:11 -0500
commitb6d6756c698175c19fd9f98fca0f9eb12adb4ed8 (patch)
treee1899be5eace25139332e71f403fc33e35170e99 /gui-apps/mako/mako-1.5.ebuild
parentapp-admin/ansible-base: 2.10.9 bump (diff)
downloadgentoo-b6d6756c698175c19fd9f98fca0f9eb12adb4ed8.tar.gz
gentoo-b6d6756c698175c19fd9f98fca0f9eb12adb4ed8.tar.bz2
gentoo-b6d6756c698175c19fd9f98fca0f9eb12adb4ed8.zip
gui-apps/mako: 1.5 bump
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'gui-apps/mako/mako-1.5.ebuild')
-rw-r--r--gui-apps/mako/mako-1.5.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/gui-apps/mako/mako-1.5.ebuild b/gui-apps/mako/mako-1.5.ebuild
new file mode 100644
index 000000000000..ce59067b0376
--- /dev/null
+++ b/gui-apps/mako/mako-1.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A lightweight notification daemon for Wayland. Works on Sway."
+HOMEPAGE="https://github.com/emersion/mako"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+icons"
+
+DEPEND="
+ dev-libs/wayland
+ x11-libs/pango
+ x11-libs/cairo
+ || (
+ sys-apps/systemd
+ sys-auth/elogind
+ )
+ sys-apps/dbus[user-session]
+ icons? (
+ x11-libs/gtk+:3
+ x11-libs/gdk-pixbuf
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ dev-libs/wayland-protocols
+"
+BDEPEND="
+ virtual/pkgconfig
+ app-text/scdoc
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dicons=$(usex icons enabled disabled)
+ "-Dwerror=false"
+ )
+ meson_src_configure
+}