summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-05 17:57:09 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-05 17:57:26 -0500
commite56e758cf7fff5f509f14b2eb1c3fc4d90fc7076 (patch)
tree2026c8b75b0c107dfc8bc8b6f0a5a14681832cc8 /gui-apps/mako
parentsys-kernel/vanilla-sources: Automated version bump to {4.9.168,4.14.111,4.19.... (diff)
downloadgentoo-e56e758cf7fff5f509f14b2eb1c3fc4d90fc7076.tar.gz
gentoo-e56e758cf7fff5f509f14b2eb1c3fc4d90fc7076.tar.bz2
gentoo-e56e758cf7fff5f509f14b2eb1c3fc4d90fc7076.zip
gui-apps/mako: initial add of gui-apps/mako
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'gui-apps/mako')
-rw-r--r--gui-apps/mako/Manifest1
-rw-r--r--gui-apps/mako/mako-1.2.ebuild46
-rw-r--r--gui-apps/mako/mako-9999.ebuild51
-rw-r--r--gui-apps/mako/metadata.xml19
4 files changed, 117 insertions, 0 deletions
diff --git a/gui-apps/mako/Manifest b/gui-apps/mako/Manifest
new file mode 100644
index 000000000000..d78133185877
--- /dev/null
+++ b/gui-apps/mako/Manifest
@@ -0,0 +1 @@
+DIST mako-1.2.tar.gz 34443 BLAKE2B d505cbc7d25755ef3880adceaf8e33c277a90583c37ebd2691cd3d8d142f19f7eedca2ad167c0174723706c6f0a9b0688ddb34ed824e8231330265f1b5e3d645 SHA512 2552590f690a9749e9ef897052ca6aecf70eb01d77b1afe21335c84e257c6c8347abbd7f33150d561e8f52a9ae3a91c7a199a93cecf64a305934886522fc1454
diff --git a/gui-apps/mako/mako-1.2.ebuild b/gui-apps/mako/mako-1.2.ebuild
new file mode 100644
index 000000000000..597b35d6e7da
--- /dev/null
+++ b/gui-apps/mako/mako-1.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A lightweight notification daemon for Wayland. Works on Sway."
+HOMEPAGE="https://github.com/emersion/mako"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-libs/wayland
+ x11-libs/pango
+ x11-libs/cairo
+ || (
+ sys-apps/systemd
+ sys-auth/elogind
+ )
+ sys-apps/dbus[user-session]
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+ app-text/scdoc
+"
+
+src_configure() {
+ local emesonargs=(
+ "-Dwerror=false"
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/mako/mako-9999.ebuild b/gui-apps/mako/mako-9999.ebuild
new file mode 100644
index 000000000000..8f1e8cc64cbb
--- /dev/null
+++ b/gui-apps/mako/mako-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A lightweight notification daemon for Wayland. Works on Sway."
+HOMEPAGE="https://github.com/emersion/mako"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+icons"
+
+DEPEND="
+ dev-libs/wayland
+ x11-libs/pango
+ x11-libs/cairo
+ || (
+ sys-apps/systemd
+ sys-auth/elogind
+ )
+ sys-apps/dbus[user-session]
+ icons? (
+ x11-libs/gtk+:3
+ x11-libs/gdk-pixbuf
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+ app-text/scdoc
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dicons=$(usex icons enabled disabled)
+ "-Dwerror=false"
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/mako/metadata.xml b/gui-apps/mako/metadata.xml
new file mode 100644
index 000000000000..f4af030a3eca
--- /dev/null
+++ b/gui-apps/mako/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ A lightweight notification daemon for Wayland. Works on Sway.
+ </longdescription>
+ <use>
+ <flag name="icons">Enable support for icons</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">emmersion/mako</remote-id>
+ <bugs-to>https://github.com/emersion/mako/issues</bugs-to>
+ <changelog>https://github.com/emersion/mako/releases</changelog>
+ </upstream>
+</pkgmetadata>