summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThiago Donato Ferreira <flowlnlnln@gmail.com>2022-07-16 14:07:03 -0300
committerJoonas Niilola <juippis@gentoo.org>2022-07-25 09:04:41 +0300
commit97eea123a40bd45af96d4a7b2efacc0b5c0e657c (patch)
treec9fc4fe0c2d89829e24bcab859a96f303e35f9a1 /gui-apps/swappy/swappy-1.4.0.ebuild
parentgui-apps/swappy: bump EAPI to version 8 (diff)
downloadgentoo-97eea123a40bd45af96d4a7b2efacc0b5c0e657c.tar.gz
gentoo-97eea123a40bd45af96d4a7b2efacc0b5c0e657c.tar.bz2
gentoo-97eea123a40bd45af96d4a7b2efacc0b5c0e657c.zip
gui-apps/swappy: add 1.4.0
Signed-off-by: Thiago Donato Ferreira <flowlnlnln@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/26444 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'gui-apps/swappy/swappy-1.4.0.ebuild')
-rw-r--r--gui-apps/swappy/swappy-1.4.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/gui-apps/swappy/swappy-1.4.0.ebuild b/gui-apps/swappy/swappy-1.4.0.ebuild
new file mode 100644
index 000000000000..7467b4743b6b
--- /dev/null
+++ b/gui-apps/swappy/swappy-1.4.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg optfeature
+
+DESCRIPTION="A Wayland native snapshot and editor tool, inspired by Snappy on macOS"
+HOMEPAGE="https://github.com/jtheoof/swappy"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jtheoof/swappy"
+else
+ SRC_URI="https://github.com/jtheoof/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="
+ dev-libs/glib:2
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/pango
+"
+RDEPEND="${DEPEND}
+ media-fonts/fontawesome[otf]
+"
+BDEPEND="
+ app-text/scdoc
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=enabled
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "persisting clipboard after closing" gui-apps/wl-clipboard
+}