summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-05-03 13:25:12 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-05-03 13:32:47 -0500
commit0aa2bb4b478cbd99b4b2e6658d526d210ac532d2 (patch)
treeb8a5c36a9d502927027bb0f701211bf4540f2bb6 /gui-apps/swaybg/swaybg-1.0.ebuild
parentgui-apps/swaylock: 1.4 bump (diff)
downloadgentoo-0aa2bb4b478cbd99b4b2e6658d526d210ac532d2.tar.gz
gentoo-0aa2bb4b478cbd99b4b2e6658d526d210ac532d2.tar.bz2
gentoo-0aa2bb4b478cbd99b4b2e6658d526d210ac532d2.zip
gui-apps/swaybg: 1.0 release
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'gui-apps/swaybg/swaybg-1.0.ebuild')
-rw-r--r--gui-apps/swaybg/swaybg-1.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/gui-apps/swaybg/swaybg-1.0.ebuild b/gui-apps/swaybg/swaybg-1.0.ebuild
new file mode 100644
index 000000000000..3de08375f038
--- /dev/null
+++ b/gui-apps/swaybg/swaybg-1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A wallpaper utility for Wayland"
+HOMEPAGE="https://github.com/swaywm/swaybg"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+else
+ SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man"
+
+DEPEND="
+ dev-libs/wayland
+"
+RDEPEND="
+ ${DEPEND}
+ !<=gui-wm/sway-1.1
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.14
+ x11-libs/gdk-pixbuf
+ x11-libs/cairo
+ virtual/pkgconfig
+ man? ( app-text/scdoc )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=$(usex man enabled disabled)
+ "-Dwerror=false"
+ )
+
+ meson_src_configure
+}