summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-29 22:28:47 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-29 22:34:56 -0500
commite3cc52f2b4aafade01fd78685910b544d28fe0ef (patch)
treee969f87a8b7ba9aa7209ba1790c5fc6deba0cd5f /gui-apps/swaybg/swaybg-9999.ebuild
parentsys-apps/portage: version bump to 2.3.66 (diff)
downloadgentoo-e3cc52f2b4aafade01fd78685910b544d28fe0ef.tar.gz
gentoo-e3cc52f2b4aafade01fd78685910b544d28fe0ef.tar.bz2
gentoo-e3cc52f2b4aafade01fd78685910b544d28fe0ef.zip
gui-apps/swaybg: initial add
Bug: https://bugs.gentoo.org/684622 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'gui-apps/swaybg/swaybg-9999.ebuild')
-rw-r--r--gui-apps/swaybg/swaybg-9999.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/gui-apps/swaybg/swaybg-9999.ebuild b/gui-apps/swaybg/swaybg-9999.ebuild
new file mode 100644
index 000000000000..79643a572c66
--- /dev/null
+++ b/gui-apps/swaybg/swaybg-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A wallpaper utility for Wayland"
+HOMEPAGE="https://github.com/swaywm/swaybg"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+else
+ SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man"
+
+DEPEND="
+ dev-libs/wayland
+"
+RDEPEND="
+ ${DEPEND}
+ !<=gui-wm/sway-1.1
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.14
+ x11-libs/gdk-pixbuf
+ x11-libs/cairo
+ virtual/pkgconfig
+ man? ( app-text/scdoc )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=$(usex man enabled disabled)
+ "-Dwerror=false"
+ )
+
+ meson_src_configure
+}