summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-03-07 15:40:49 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2022-03-07 15:41:01 -0600
commitb9a55a9c52045e3eb7cd2f5afa07e458d4d64fbc (patch)
treee9d0c6c6199732ce4031be2e3e4d0c6d886a1bd5 /gui-apps/swaylock
parentnet-misc/freerdp: add 2.6.1 (diff)
downloadgentoo-b9a55a9c52045e3eb7cd2f5afa07e458d4d64fbc.tar.gz
gentoo-b9a55a9c52045e3eb7cd2f5afa07e458d4d64fbc.tar.bz2
gentoo-b9a55a9c52045e3eb7cd2f5afa07e458d4d64fbc.zip
gui-apps/swaylock: bump to 1.6
new release for... Bug: https://bugs.gentoo.org/834716 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'gui-apps/swaylock')
-rw-r--r--gui-apps/swaylock/Manifest1
-rw-r--r--gui-apps/swaylock/swaylock-1.6.ebuild55
-rw-r--r--gui-apps/swaylock/swaylock-9999.ebuild4
3 files changed, 58 insertions, 2 deletions
diff --git a/gui-apps/swaylock/Manifest b/gui-apps/swaylock/Manifest
index ae3b36d8cbf7..3bdacc667c13 100644
--- a/gui-apps/swaylock/Manifest
+++ b/gui-apps/swaylock/Manifest
@@ -1,2 +1,3 @@
DIST swaylock-1.3.tar.gz 32848 BLAKE2B 81ed50839bcb0139e7fc2081bd37e738f3e6ef23e96a5108d1acf56cc3425285f7382576a54201f1bf188883b1da06492074c091877af13832c0140e4e6099fd SHA512 723d758d76f076f3f1539ea0d651f6ad2562659c72eef7e895d7827a0be21db663652fe4ce2609065aff45ff20230879599868cff327ab52b896330ca04d78c4
DIST swaylock-1.5.tar.gz 35350 BLAKE2B c68073d6154842c2cdb99836bda991560605f6ede66c6124986c3395575a4e2c22d59a837a09033d1632b61628e45b18b3ee5ca198bafe4fbd8f429cb0401eda SHA512 16dd9b912ca702849290cf18d91ffbd64a70118cc284982a84b567c4974fd4590b12707c0aae1fcda7ccd1caa7880f342c633b9345bd795c36702916696d1f67
+DIST swaylock-1.6.tar.gz 36439 BLAKE2B 8944bbd5ec0dd719f8dc627dbf878fcf07df3f060b56bce3ab215a2c21fe43debfeac15f6ef7eba43415f3b94a75a335fd692e653ac48407c1cf10b400f8ff67 SHA512 9a472c25e53a41c461af41af31c7fc8b275754628d0b20f4e5085cd7ca514e68361293a6e93fb6fcb7632419a3c73e4578e03294af28fe62d944cc43339f280d
diff --git a/gui-apps/swaylock/swaylock-1.6.ebuild b/gui-apps/swaylock/swaylock-1.6.ebuild
new file mode 100644
index 000000000000..657a97f351df
--- /dev/null
+++ b/gui-apps/swaylock/swaylock-1.6.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit fcaps meson
+
+DESCRIPTION="Screen locker for Wayland"
+HOMEPAGE="https://github.com/swaywm/swaylock"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+else
+ SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+gdk-pixbuf +man +pam"
+
+DEPEND="
+ dev-libs/wayland
+ x11-libs/cairo
+ x11-libs/libxkbcommon
+ gdk-pixbuf? ( x11-libs/gdk-pixbuf:2 )
+ pam? ( sys-libs/pam )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.14
+ virtual/pkgconfig
+ man? ( app-text/scdoc )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=$(usex man enabled disabled)
+ -Dpam=$(usex pam enabled disabled)
+ -Dgdk-pixbuf=$(usex gdk-pixbuf enabled disabled)
+ "-Dfish-completions=true"
+ "-Dzsh-completions=true"
+ "-Dbash-completions=true"
+ "-Dwerror=false"
+ )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ if ! use pam; then
+ fcaps cap_sys_admin usr/bin/swaylock
+ fi
+}
diff --git a/gui-apps/swaylock/swaylock-9999.ebuild b/gui-apps/swaylock/swaylock-9999.ebuild
index c80f325049f7..657a97f351df 100644
--- a/gui-apps/swaylock/swaylock-9999.ebuild
+++ b/gui-apps/swaylock/swaylock-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,7 +13,7 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
else
SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
fi
LICENSE="MIT"