summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-07-11 17:36:54 -0400
committerAaron Bauman <bman@gentoo.org>2020-07-20 21:48:36 -0400
commit9350b030dd15895826f46ac1af92fe6ef1efb3a1 (patch)
treebb233ed39024ecbe28bfb31cc9921dc053e7c933 /gui-apps/tuigreet/tuigreet-0.1.1.ebuild
parentmedia-fonts/fontawesome: version bump to 5.14.0 (diff)
downloadgentoo-9350b030dd15895826f46ac1af92fe6ef1efb3a1.tar.gz
gentoo-9350b030dd15895826f46ac1af92fe6ef1efb3a1.tar.bz2
gentoo-9350b030dd15895826f46ac1af92fe6ef1efb3a1.zip
gui-apps/tuigreet: version bump to 0.1.1
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'gui-apps/tuigreet/tuigreet-0.1.1.ebuild')
-rw-r--r--gui-apps/tuigreet/tuigreet-0.1.1.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/gui-apps/tuigreet/tuigreet-0.1.1.ebuild b/gui-apps/tuigreet/tuigreet-0.1.1.ebuild
new file mode 100644
index 000000000000..0edb32398bc1
--- /dev/null
+++ b/gui-apps/tuigreet/tuigreet-0.1.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 2017-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CRATES="
+ahash-0.3.8
+autocfg-1.0.0
+bitflags-1.2.1
+cassowary-0.3.0
+cc-1.0.55
+cfg-if-0.1.10
+chrono-0.4.11
+dlv-list-0.2.2
+either-1.5.3
+getopts-0.2.21
+getrandom-0.1.14
+greetd_ipc-0.6.0
+hashbrown-0.7.2
+itertools-0.9.0
+itoa-0.4.6
+libc-0.2.71
+nix-0.17.0
+num-integer-0.1.43
+num-traits-0.2.12
+numtoa-0.1.0
+ordered-multimap-0.2.4
+ppv-lite86-0.2.8
+proc-macro2-1.0.18
+quote-1.0.7
+rand-0.7.3
+rand_chacha-0.2.2
+rand_core-0.5.1
+rand_hc-0.2.0
+redox_syscall-0.1.56
+redox_termios-0.1.1
+rust-ini-0.15.3
+ryu-1.0.5
+serde-1.0.114
+serde_derive-1.0.114
+serde_json-1.0.55
+syn-1.0.33
+termion-1.5.5
+textwrap-0.12.0
+thiserror-1.0.20
+thiserror-impl-1.0.20
+time-0.1.43
+tui-0.9.5
+unicode-segmentation-1.6.0
+unicode-width-0.1.7
+unicode-xid-0.2.1
+void-1.0.2
+wasi-0.9.0+wasi-snapshot-preview1
+winapi-0.3.9
+winapi-i686-pc-windows-gnu-0.4.0
+winapi-x86_64-pc-windows-gnu-0.4.0
+zeroize-1.1.0
+"
+
+inherit cargo
+
+DESCRIPTION="TUI greeter for greetd login manager"
+HOMEPAGE="https://github.com/apognu/tuigreet"
+
+SRC_URI="https://github.com/apognu/tuigreet/archive/${PV}.tar.gz -> ${P}.tar.gz
+ $(cargo_crate_uris ${CRATES})"
+
+QA_FLAGS_IGNORED="usr/bin/tuigreet"
+
+LICENSE="Apache-2.0 Boost-1.0 GPL-3 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+RDEPEND="gui-libs/greetd"