summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-05-15 11:55:19 -0400
committerAaron Bauman <bman@gentoo.org>2020-05-17 11:54:36 -0400
commit3713d3b1fb431a194478075fb408aa9301e44018 (patch)
tree344a97a0c33a0786284c17fa4ea2d279b8022393 /gui-apps/wcm/wcm-9999.ebuild
parentgui-wm/wayfire: compiz like 3d wayland manager (diff)
downloadgentoo-3713d3b1fb431a194478075fb408aa9301e44018.tar.gz
gentoo-3713d3b1fb431a194478075fb408aa9301e44018.tar.bz2
gentoo-3713d3b1fb431a194478075fb408aa9301e44018.zip
gui-apps/wcm: wayfire config manager
Closes: https://bugs.gentoo.org/713884 configuration parser and generator, which allows you to reload the config on the fly without needing to restart wayfire Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'gui-apps/wcm/wcm-9999.ebuild')
-rw-r--r--gui-apps/wcm/wcm-9999.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/gui-apps/wcm/wcm-9999.ebuild b/gui-apps/wcm/wcm-9999.ebuild
new file mode 100644
index 000000000000..8178a3b0d885
--- /dev/null
+++ b/gui-apps/wcm/wcm-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Wayfire Config Manager"
+HOMEPAGE="https://github.com/WayfireWM/wcm"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
+else
+ SRC_URI="https://github.com/WayfireWM/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="
+ dev-libs/libevdev
+ dev-libs/libxml2
+ dev-cpp/gtkmm:3.0[wayland]
+ ~gui-wm/wayfire-${PV}[debug=]
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ ${DEPEND}
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"
+
+src_compile() {
+ local emesonargs=""
+ if use debug; then
+ emesonargs+=(
+ "-Db_sanitize=address,undefined"
+ )
+ fi
+ meson_src_compile
+}