summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <aisha@bsd.ac>2023-02-12 07:47:20 -0500
committerSam James <sam@gentoo.org>2023-02-13 00:39:03 +0000
commit9078d818be3d527cb5b8a9e2da3a97775484f457 (patch)
tree99b48659a68f41f689ad4244f2c2c1e16427752e /gui-apps/wcm
parentgui-wm/wayfire: add 0.7.5 (diff)
downloadgentoo-9078d818be3d527cb5b8a9e2da3a97775484f457.tar.gz
gentoo-9078d818be3d527cb5b8a9e2da3a97775484f457.tar.bz2
gentoo-9078d818be3d527cb5b8a9e2da3a97775484f457.zip
gui-apps/wcm: add 0.7.5
Closes: https://bugs.gentoo.org/884055 Signed-off-by: Aisha Tammy <aisha@bsd.ac> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gui-apps/wcm')
-rw-r--r--gui-apps/wcm/Manifest1
-rw-r--r--gui-apps/wcm/wcm-0.7.5.ebuild34
-rw-r--r--gui-apps/wcm/wcm-9999.ebuild4
3 files changed, 37 insertions, 2 deletions
diff --git a/gui-apps/wcm/Manifest b/gui-apps/wcm/Manifest
index ae75d377f434..b31d3ba2088e 100644
--- a/gui-apps/wcm/Manifest
+++ b/gui-apps/wcm/Manifest
@@ -1 +1,2 @@
DIST wcm-0.7.0.tar.xz 263952 BLAKE2B 6e8761b75d5e37e49a1ba1e9b2a045c7350fa28642d26f1f66b0513fdb4130495f43bcae137184bf5bd2f0f2a0d5a81891459819d692a84b66b96c7d1440ee7e SHA512 190d8befafac69c27d99d10113160a1806a9dbd83f740216dd38e9cbe3c2638817b3471c9f46b60642e91abe02fbb72458b61f07bda9cd5fc5dbc7cdf880c6bb
+DIST wcm-0.7.5.tar.xz 394096 BLAKE2B cf0fe0d1c1e1fa2660a28a61cd9d52ac6fa3c9cceab43788b75f4359e1495dd2ddd767cb1f030afec4dadc2b7ef3c260ba83566a70a794dee8d3bb34427754fd SHA512 d41def6cd002405c5fe81502cd19fb958399d25709e35fd5ffdfb862d6c5011f75c9ddf9110b40519a570457870ed2290c92c96f29a3be7db1e7802e122ebbe2
diff --git a/gui-apps/wcm/wcm-0.7.5.ebuild b/gui-apps/wcm/wcm-0.7.5.ebuild
new file mode 100644
index 000000000000..d91c7aa57b64
--- /dev/null
+++ b/gui-apps/wcm/wcm-0.7.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg
+
+DESCRIPTION="Wayfire Config Manager"
+HOMEPAGE="https://github.com/WayfireWM/wcm"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/wcm.git"
+else
+ SRC_URI="https://github.com/WayfireWM/wcm/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="
+ dev-libs/libevdev
+ dev-libs/libxml2
+ dev-cpp/gtkmm:3.0[wayland]
+ >=gui-wm/wayfire-${PV%.*}
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"
diff --git a/gui-apps/wcm/wcm-9999.ebuild b/gui-apps/wcm/wcm-9999.ebuild
index 9f49e9cfad09..d91c7aa57b64 100644
--- a/gui-apps/wcm/wcm-9999.ebuild
+++ b/gui-apps/wcm/wcm-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 2019-2021 Gentoo Authors
+# Copyright 2019-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit meson xdg