summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-02-24 20:51:37 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2019-02-24 20:52:46 -0600
commit74fdbccce471ac1629f721fe3d6705dfa42a2b6b (patch)
tree6ddcdef7ee0061733e5285e302a6e10883d518c0 /gui-apps/wl-clipboard/wl-clipboard-1.0.0.ebuild
parentdev-php/php-redmine-api: new version 1.5.16. (diff)
downloadgentoo-74fdbccce471ac1629f721fe3d6705dfa42a2b6b.tar.gz
gentoo-74fdbccce471ac1629f721fe3d6705dfa42a2b6b.tar.bz2
gentoo-74fdbccce471ac1629f721fe3d6705dfa42a2b6b.zip
add move for wl-clipboard
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'gui-apps/wl-clipboard/wl-clipboard-1.0.0.ebuild')
-rw-r--r--gui-apps/wl-clipboard/wl-clipboard-1.0.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/gui-apps/wl-clipboard/wl-clipboard-1.0.0.ebuild b/gui-apps/wl-clipboard/wl-clipboard-1.0.0.ebuild
new file mode 100644
index 000000000000..d7fcf5337472
--- /dev/null
+++ b/gui-apps/wl-clipboard/wl-clipboard-1.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Wayland clipboard utilities"
+HOMEPAGE="https://github.com/bugaevc/wl-clipboard"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/bugaevc/${PN}.git"
+else
+ SRC_URI="https://github.com/bugaevc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/wayland"
+RDEPEND="${DEPEND}"
+BDEPEND=""