summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-10-03 13:45:20 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-10-03 13:49:54 -0500
commit7ef0bd81c2f9467f08d9d275cb4fce9574616aaf (patch)
tree03d249afa88435700d4fc39896afa87af9a7303a /gui-apps/wl-clipboard/wl-clipboard-2.0.0.ebuild
parentkde-apps/kdepim-runtime: Add another upstream race condition fix (diff)
downloadgentoo-7ef0bd81c2f9467f08d9d275cb4fce9574616aaf.tar.gz
gentoo-7ef0bd81c2f9467f08d9d275cb4fce9574616aaf.tar.bz2
gentoo-7ef0bd81c2f9467f08d9d275cb4fce9574616aaf.zip
gui-apps/wl-clipboard: 2.0.0 bump
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'gui-apps/wl-clipboard/wl-clipboard-2.0.0.ebuild')
-rw-r--r--gui-apps/wl-clipboard/wl-clipboard-2.0.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/gui-apps/wl-clipboard/wl-clipboard-2.0.0.ebuild b/gui-apps/wl-clipboard/wl-clipboard-2.0.0.ebuild
new file mode 100644
index 000000000000..d7fcf5337472
--- /dev/null
+++ b/gui-apps/wl-clipboard/wl-clipboard-2.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Wayland clipboard utilities"
+HOMEPAGE="https://github.com/bugaevc/wl-clipboard"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/bugaevc/${PN}.git"
+else
+ SRC_URI="https://github.com/bugaevc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/wayland"
+RDEPEND="${DEPEND}"
+BDEPEND=""