summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-11-05 21:52:57 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-11-05 22:10:10 +0100
commit4c79e0856ad19c3ca6edab222aa5b95e48442925 (patch)
tree55265a74497592ed593a727e79a8d4823068fc06 /gui-apps/xwaylandvideobridge
parentdev-python/zope-i18nmessageid: Remove old (diff)
downloadgentoo-4c79e0856ad19c3ca6edab222aa5b95e48442925.tar.gz
gentoo-4c79e0856ad19c3ca6edab222aa5b95e48442925.tar.bz2
gentoo-4c79e0856ad19c3ca6edab222aa5b95e48442925.zip
gui-apps/xwaylandvideobridge: add 0.3.0
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'gui-apps/xwaylandvideobridge')
-rw-r--r--gui-apps/xwaylandvideobridge/Manifest1
-rw-r--r--gui-apps/xwaylandvideobridge/xwaylandvideobridge-0.3.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/gui-apps/xwaylandvideobridge/Manifest b/gui-apps/xwaylandvideobridge/Manifest
index 2e3f771adec2..f2c80865f5cf 100644
--- a/gui-apps/xwaylandvideobridge/Manifest
+++ b/gui-apps/xwaylandvideobridge/Manifest
@@ -1 +1,2 @@
+DIST xwaylandvideobridge-0.3.0.tar.xz 35584 BLAKE2B 10d0770efc023a3c52bcc7af119d13cf2d38cd9c6d4d0e7a19a46ae455428a7b2fc03a8b61a8036a15210d699193c71784962c60ad82a65a385414b426c20e78 SHA512 9e86fac3dbed2c2cca1b899a8266c8feda3263544048c3e554e3029f065053637dda84fc0fcc10be5d4856015743b0cdcb8e0e18cd26d14739fb7481850b1392
DIST xwaylandvideobridge-0_pre20230819-8842032f.tar.gz 34466 BLAKE2B 7407638cab2476f56c6e0b402e8683af7145e9acc47240635161bc780467eafa91cc11d720916ac3ce36e401bda65b8d9a244de994cd72193c58ca385f0b1f2a SHA512 8ea099fa2719b715d35eadc5224477470a6ca226bb388098b4c1423a62f23c1e7c52222093cb126e2af7f898be5a04f63294d350d4907aaf35e2e726940477d4
diff --git a/gui-apps/xwaylandvideobridge/xwaylandvideobridge-0.3.0.ebuild b/gui-apps/xwaylandvideobridge/xwaylandvideobridge-0.3.0.ebuild
new file mode 100644
index 000000000000..1d58263f2e49
--- /dev/null
+++ b/gui-apps/xwaylandvideobridge/xwaylandvideobridge-0.3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.106.0
+QTMIN=5.15.9
+KDE_ORG_CATEGORY="system"
+inherit ecm kde.org
+
+DESCRIPTION="Screenshare Wayland windows to XWayland apps"
+HOMEPAGE="https://planet.kde.org/david-edmundson-2023-03-22-fixing-wayland-xwayland-screen-casting/
+https://invent.kde.org/system/xwaylandvideobridge"
+
+if [[ ${KDE_BUILD_TYPE} == release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-plasma/kpipewire-5.27.4:5
+ media-libs/freetype
+ x11-libs/libxcb:=
+ x11-libs/xcb-util
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"