summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-08-05 07:21:42 -0400
committerAaron Bauman <bman@gentoo.org>2020-08-16 21:36:07 -0400
commit101961ecf903c3ed8abbf3c77ad5c87fc2cd2239 (patch)
tree27c1ea522ac657f97e5a639b2e3d342647902298 /gui-apps
parentgui-apps/wf-shell: version bump to 0.5.0 (diff)
downloadgentoo-101961ecf903c3ed8abbf3c77ad5c87fc2cd2239.tar.gz
gentoo-101961ecf903c3ed8abbf3c77ad5c87fc2cd2239.tar.bz2
gentoo-101961ecf903c3ed8abbf3c77ad5c87fc2cd2239.zip
gui-apps/wcm: version bump to 0.5.0
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Closes: https://github.com/gentoo/gentoo/pull/17014 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/wcm/Manifest1
-rw-r--r--gui-apps/wcm/wcm-0.5.0.ebuild34
-rw-r--r--gui-apps/wcm/wcm-9999.ebuild3
3 files changed, 36 insertions, 2 deletions
diff --git a/gui-apps/wcm/Manifest b/gui-apps/wcm/Manifest
index ec440af0389f..f44a1542cd96 100644
--- a/gui-apps/wcm/Manifest
+++ b/gui-apps/wcm/Manifest
@@ -1 +1,2 @@
DIST wcm-0.4.0.tar.gz 263841 BLAKE2B 28cdf87c479cc7a4a5a40f17a1ec26688bae6a0cd5699b51ad7db2adca89946d7687ae345a7a82d71464df413c956aceeb3db8195c5b40da5f32043821883c49 SHA512 4136ceba90c054165b4b0e7a79d78af827d8b8ddb8b54820bda0c17bbaa28eb74981ce94d8c386b91257ca023a34f76f121a003229365afe72d65323f0a1d2cd
+DIST wcm-0.5.0.tar.gz 253120 BLAKE2B 44f6e36425ed070f086fcea6b3374b8fd2f1e3420176098699ec735cb74a1de0d6919ca71e62ca61116005ad26e50562e0a927dce7990d87eb7559511fb371e3 SHA512 c06e97fa3b22f33bb7f05efda380484377596cce83b7874d42b6f3795f275faee2fdd2f2a6a6f24ebbb7e339a0dd3e526a3d02a2e1d4c45b34f76d627896bc53
diff --git a/gui-apps/wcm/wcm-0.5.0.ebuild b/gui-apps/wcm/wcm-0.5.0.ebuild
new file mode 100644
index 000000000000..375772702783
--- /dev/null
+++ b/gui-apps/wcm/wcm-0.5.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Wayfire Config Manager"
+HOMEPAGE="https://github.com/WayfireWM/wcm"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/wcm.git"
+else
+ SRC_URI="https://github.com/WayfireWM/wcm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="
+ dev-libs/libevdev
+ dev-libs/libxml2
+ dev-cpp/gtkmm:3.0[wayland]
+ >=gui-wm/wayfire-${PV}
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"
diff --git a/gui-apps/wcm/wcm-9999.ebuild b/gui-apps/wcm/wcm-9999.ebuild
index 54d7e4cee824..375772702783 100644
--- a/gui-apps/wcm/wcm-9999.ebuild
+++ b/gui-apps/wcm/wcm-9999.ebuild
@@ -23,13 +23,12 @@ DEPEND="
dev-libs/libevdev
dev-libs/libxml2
dev-cpp/gtkmm:3.0[wayland]
- ~gui-wm/wayfire-${PV}
+ >=gui-wm/wayfire-${PV}
"
RDEPEND="${DEPEND}"
BDEPEND="
- ${DEPEND}
dev-libs/wayland-protocols
virtual/pkgconfig
"