summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-07-07 11:00:02 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2022-07-07 11:10:02 -0500
commit17259f5db338335f177cc6c3277e6885a427b404 (patch)
treefe436155ceb756ae278bd8d3505941df70f4417a /gui-apps
parentprofiles: mask broken virtualbox revisions (diff)
downloadgentoo-17259f5db338335f177cc6c3277e6885a427b404.tar.gz
gentoo-17259f5db338335f177cc6c3277e6885a427b404.tar.bz2
gentoo-17259f5db338335f177cc6c3277e6885a427b404.zip
gui-apps/mako: 1.7.1 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/mako/Manifest1
-rw-r--r--gui-apps/mako/mako-1.7.1.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/gui-apps/mako/Manifest b/gui-apps/mako/Manifest
index cef4811e1719..9d60d69ce201 100644
--- a/gui-apps/mako/Manifest
+++ b/gui-apps/mako/Manifest
@@ -1 +1,2 @@
DIST mako-1.6.tar.gz 60468 BLAKE2B 77fcd52e69d6e253d0afb2b0057c94090c0ad6f6bd929eafb88808ad7b7a0deb76f06af99de8bc94064436c47a4110aa2314557b7ff068ba482f285f2ea23e13 SHA512 1b503779b5607ae072d72ba43a2c4557fdf9fdad113e5a2370eb2e603e51422b3a483ac5f4a948ae33d62e7d9e86a6bbc89b2cba98647c4789505a49981c8baf
+DIST mako-1.7.1.tar.gz 62511 BLAKE2B 2556e0be7181999624cfa09898649c61a18691559c9693660db0ff79966bead32c327f217ecc66110526f5dfe02154083334ae8fa82f110869a59f29fa9bc5ae SHA512 a6066327fe6f19eb2717773dca0ea52eb1ad5c402780d12aa07b184f8a11c27a7c77e5c037cd9ff618bce35caa740da1af6ad3b41509e80e75ab5c0efb032588
diff --git a/gui-apps/mako/mako-1.7.1.ebuild b/gui-apps/mako/mako-1.7.1.ebuild
new file mode 100644
index 000000000000..043c21616341
--- /dev/null
+++ b/gui-apps/mako/mako-1.7.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="A lightweight notification daemon for Wayland. Works on Sway"
+HOMEPAGE="https://github.com/emersion/mako"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="elogind +icons systemd"
+
+DEPEND="
+ dev-libs/wayland
+ x11-libs/pango
+ x11-libs/cairo
+ || (
+ systemd? ( sys-apps/systemd )
+ elogind? ( sys-auth/elogind )
+ sys-libs/basu
+ )
+ sys-apps/dbus
+ icons? (
+ x11-libs/gtk+:3
+ x11-libs/gdk-pixbuf
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ >=dev-libs/wayland-protocols-1.21
+"
+BDEPEND="
+ virtual/pkgconfig
+ app-text/scdoc
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dicons=$(usex icons enabled disabled)
+ )
+
+ if use systemd ; then
+ emesonargs+=( -Dsd-bus-provider=libsystemd )
+ elif use elogind ; then
+ emesonargs+=( -Dsd-bus-provider=libelogind )
+ else
+ emesonargs+=( -Dsd-bus-provider=basu )
+ fi
+
+ meson_src_configure
+}