summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Toth <gentoo@jonas-toth.eu>2021-04-30 11:37:56 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-05-18 13:28:21 +0300
commit1b333c986ca58fb8a5b64a218a9a3202d4c39ee2 (patch)
treef8bf3ea2ee2fe7602a2e7a654954468fe5930c5f /gui-apps
parentdev-lang/janet: drop 1.12.2 (diff)
downloadgentoo-1b333c986ca58fb8a5b64a218a9a3202d4c39ee2.tar.gz
gentoo-1b333c986ca58fb8a5b64a218a9a3202d4c39ee2.tar.bz2
gentoo-1b333c986ca58fb8a5b64a218a9a3202d4c39ee2.zip
gui-apps/waybar: version bump to 0.9.7
Version 0.9.6 is skipped because it required a hotfix release, which is 0.9.7. Check the upstream release notes for more information. - [0.9.6](https://github.com/Alexays/Waybar/releases/tag/0.9.6) - [0.9.7](https://github.com/Alexays/Waybar/releases/tag/0.9.7) Signed-off-by: Jonas Toth <gentoo@jonas-toth.eu> Closes: https://github.com/gentoo/gentoo/pull/20613 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/waybar/Manifest1
-rw-r--r--gui-apps/waybar/waybar-0.9.7.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/gui-apps/waybar/Manifest b/gui-apps/waybar/Manifest
index 24bd5159b91f..01903c569128 100644
--- a/gui-apps/waybar/Manifest
+++ b/gui-apps/waybar/Manifest
@@ -1 +1,2 @@
DIST waybar-0.9.5.tar.gz 146094 BLAKE2B cd46e308d282df5ba6ce34417c0fe5468c188acb3c0f9bf5b2d4dd4c2c80547cab65172b4f4162c2dde0b78f68d15c8b79be74113cacd2610fd2a48299e14013 SHA512 0bbb9e898e205728fc564389927fec661a8dd6a9995a6c5d318f930f4527d6afd0be11a6b71dfa9aafb05c982e0f131e51eb0eec9a3e92c28f5cb04ff780fa8b
+DIST waybar-0.9.7.tar.gz 150768 BLAKE2B 41dbcac30ffc42e04d565a590c1bce086271938936a05599bca6b74bac3fb2a8d1a4a4ddc5bec079dea6963eef8722c2c87a99c066de495caa163b1103a08095 SHA512 731b686235b1f0f94ce263e7ffa854f980fb8fccf30a0bd89e7aa0e1ca2c3fabd6d0df837bace6d6915d7a633500ed1f0497d012e082ca99fb32a78142b99279
diff --git a/gui-apps/waybar/waybar-0.9.7.ebuild b/gui-apps/waybar/waybar-0.9.7.ebuild
new file mode 100644
index 000000000000..0094f250d489
--- /dev/null
+++ b/gui-apps/waybar/waybar-0.9.7.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Highly customizable Wayland bar for Sway and Wlroots based compositors"
+HOMEPAGE="https://github.com/Alexays/Waybar"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Alexays/${PN^}.git"
+else
+ SRC_URI="https://github.com/Alexays/${PN^}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+S="${WORKDIR}/${PN^}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="mpd network popups pulseaudio tray +udev wifi"
+
+BDEPEND="
+ >=app-text/scdoc-1.9.2
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-cpp/gtkmm:3.0
+ dev-libs/jsoncpp:=
+ dev-libs/libinput:=
+ dev-libs/libsigc++:2
+ >=dev-libs/libfmt-5.3.0:=
+ >=dev-libs/spdlog-1.8.0:=
+ dev-libs/date:=
+ dev-libs/wayland
+ dev-libs/wayland-protocols
+ gui-libs/wlroots
+ x11-libs/gtk+:3[wayland]
+ mpd? ( media-libs/libmpdclient )
+ network? ( dev-libs/libnl:3 )
+ popups? ( gui-libs/gtk-layer-shell )
+ pulseaudio? ( media-sound/pulseaudio )
+ tray? (
+ dev-libs/libdbusmenu[gtk3]
+ dev-libs/libappindicator
+ )
+ udev? ( virtual/libudev:= )
+ wifi? ( || ( sys-apps/util-linux net-wireless/rfkill ) )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature mpd)
+ $(meson_feature network libnl)
+ $(meson_feature popups gtk-layer-shell)
+ $(meson_feature pulseaudio)
+ $(meson_feature tray dbusmenu-gtk)
+ $(meson_feature udev libudev)
+ $(meson_feature wifi rfkill)
+ -Dsndio=disabled
+ )
+ meson_src_configure
+}