summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2022-07-24 14:36:24 -0500
committerJohn Helmert III <ajak@gentoo.org>2022-08-14 21:40:19 -0500
commit4e4773b156dee91fd662dab42a1bdda0a6044d17 (patch)
treec0c944d54602b1f9b54d5889929a79cd8cc35b6e /gui-apps
parentnet-misc/yt-dlp: add 2022.8.14 (diff)
downloadgentoo-4e4773b156dee91fd662dab42a1bdda0a6044d17.tar.gz
gentoo-4e4773b156dee91fd662dab42a1bdda0a6044d17.tar.bz2
gentoo-4e4773b156dee91fd662dab42a1bdda0a6044d17.zip
gui-apps/mako: install systemd user unit and completions
Closes: https://github.com/gentoo/gentoo/pull/26572 Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/mako/mako-1.7.1-r1.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/gui-apps/mako/mako-1.7.1-r1.ebuild b/gui-apps/mako/mako-1.7.1-r1.ebuild
new file mode 100644
index 000000000000..6ffde2623461
--- /dev/null
+++ b/gui-apps/mako/mako-1.7.1-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson systemd
+
+DESCRIPTION="A lightweight notification daemon for Wayland. Works on Sway"
+HOMEPAGE="https://github.com/emersion/mako"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="elogind +icons systemd"
+
+DEPEND="
+ dev-libs/wayland
+ dev-util/wayland-scanner
+ x11-libs/pango
+ x11-libs/cairo
+ || (
+ systemd? ( sys-apps/systemd )
+ elogind? ( sys-auth/elogind )
+ sys-libs/basu
+ )
+ sys-apps/dbus
+ icons? (
+ x11-libs/gtk+:3
+ x11-libs/gdk-pixbuf
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ >=dev-libs/wayland-protocols-1.21
+"
+BDEPEND="
+ virtual/pkgconfig
+ app-text/scdoc
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dicons=$(usex icons enabled disabled)
+ -Dzsh-completions=true
+ -Dfish-completions=true
+ -Dbash-completions=true
+ )
+
+ if use systemd ; then
+ emesonargs+=( -Dsd-bus-provider=libsystemd )
+ elif use elogind ; then
+ emesonargs+=( -Dsd-bus-provider=libelogind )
+ else
+ emesonargs+=( -Dsd-bus-provider=basu )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ systemd_douserunit contrib/systemd/mako.service
+}