summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2021-01-30 03:12:04 +0000
committerJoonas Niilola <juippis@gentoo.org>2021-02-10 15:36:00 +0200
commit8a08b52ef55980a0d32af1e25de840674d77d568 (patch)
treef21488c75e4242f6297e11b4e91495db5d2bb709 /gui-apps
parentgui-wm/wayfire: version bump to 0.7.0 (diff)
downloadgentoo-8a08b52ef55980a0d32af1e25de840674d77d568.tar.gz
gentoo-8a08b52ef55980a0d32af1e25de840674d77d568.tar.bz2
gentoo-8a08b52ef55980a0d32af1e25de840674d77d568.zip
gui-apps/wcm: version bump to 0.7.0
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/wcm/Manifest1
-rw-r--r--gui-apps/wcm/wcm-0.7.0.ebuild34
-rw-r--r--gui-apps/wcm/wcm-9999.ebuild4
3 files changed, 37 insertions, 2 deletions
diff --git a/gui-apps/wcm/Manifest b/gui-apps/wcm/Manifest
index 4e304edcad70..5c721250b307 100644
--- a/gui-apps/wcm/Manifest
+++ b/gui-apps/wcm/Manifest
@@ -1,2 +1,3 @@
DIST wcm-0.5.0.tar.gz 253120 BLAKE2B 44f6e36425ed070f086fcea6b3374b8fd2f1e3420176098699ec735cb74a1de0d6919ca71e62ca61116005ad26e50562e0a927dce7990d87eb7559511fb371e3 SHA512 c06e97fa3b22f33bb7f05efda380484377596cce83b7874d42b6f3795f275faee2fdd2f2a6a6f24ebbb7e339a0dd3e526a3d02a2e1d4c45b34f76d627896bc53
DIST wcm-0.6.0.tar.gz 308100 BLAKE2B 22fd0867b7efee153375844bd9b06fa7978a488494bf48c5da10ecf59ab9ff1ee49fc31e82de294d2a5bf2af5339ccd367916f3e66c9e173379679622c5d9c93 SHA512 a0ce6541ea1416585d3102a07f8ccc73d53345cdab472a9f1a839af652ccaa3b7c4ef26dbe3c24d3ff4bfb5be9a1c61a7922170dafa9a66082c0de90ebcba3d9
+DIST wcm-0.7.0.tar.xz 263952 BLAKE2B 6e8761b75d5e37e49a1ba1e9b2a045c7350fa28642d26f1f66b0513fdb4130495f43bcae137184bf5bd2f0f2a0d5a81891459819d692a84b66b96c7d1440ee7e SHA512 190d8befafac69c27d99d10113160a1806a9dbd83f740216dd38e9cbe3c2638817b3471c9f46b60642e91abe02fbb72458b61f07bda9cd5fc5dbc7cdf880c6bb
diff --git a/gui-apps/wcm/wcm-0.7.0.ebuild b/gui-apps/wcm/wcm-0.7.0.ebuild
new file mode 100644
index 000000000000..317718d415c7
--- /dev/null
+++ b/gui-apps/wcm/wcm-0.7.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Wayfire Config Manager"
+HOMEPAGE="https://github.com/WayfireWM/wcm"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/wcm.git"
+else
+ SRC_URI="https://github.com/WayfireWM/wcm/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="
+ dev-libs/libevdev
+ dev-libs/libxml2
+ dev-cpp/gtkmm:3.0[wayland]
+ >=gui-wm/wayfire-${PV%.*}
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"
diff --git a/gui-apps/wcm/wcm-9999.ebuild b/gui-apps/wcm/wcm-9999.ebuild
index 66c8ce7b2447..317718d415c7 100644
--- a/gui-apps/wcm/wcm-9999.ebuild
+++ b/gui-apps/wcm/wcm-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019-2020 Gentoo Authors
+# Copyright 2019-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,7 +12,7 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/WayfireWM/wcm.git"
else
- SRC_URI="https://github.com/WayfireWM/wcm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/WayfireWM/wcm/releases/download/v${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm64 ~x86"
fi