summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-11-11 15:09:47 -0500
committerAaron Bauman <bman@gentoo.org>2020-11-13 16:04:13 -0500
commit9896adeb3d635f5c4817e4ab309a7d2281ca3dbf (patch)
tree494b70e5a1fad61bfacf3bb63a9d8140e3bb8a26 /gui-apps
parentgui-apps/wayland-logout: new dependency for wf-shell (diff)
downloadgentoo-9896adeb3d635f5c4817e4ab309a7d2281ca3dbf.tar.gz
gentoo-9896adeb3d635f5c4817e4ab309a7d2281ca3dbf.tar.bz2
gentoo-9896adeb3d635f5c4817e4ab309a7d2281ca3dbf.zip
gui-apps/wf-shell: version bump to 0.6.1
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Closes: https://github.com/gentoo/gentoo/pull/18218 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/wf-shell/Manifest1
-rw-r--r--gui-apps/wf-shell/wf-shell-0.6.1.ebuild44
-rw-r--r--gui-apps/wf-shell/wf-shell-9999.ebuild13
3 files changed, 52 insertions, 6 deletions
diff --git a/gui-apps/wf-shell/Manifest b/gui-apps/wf-shell/Manifest
index acc3e68fe84c..5af436f3cf28 100644
--- a/gui-apps/wf-shell/Manifest
+++ b/gui-apps/wf-shell/Manifest
@@ -1 +1,2 @@
DIST wf-shell-0.5.0.tar.xz 8998296 BLAKE2B c32232fc08292b15a0048d11d0f179a82fd21b3179223d898057ac95b42ac35ec063467f67c0f1261857c3b643edc4367112a05bb63f002788b64ed86559addd SHA512 d0029746ea10625bb47381a7ed74aadb8aa3823f83f751b539eefd49da5aa1643a2d16c55fe23d30bd71528ad5c1ea8d389909fe8cc1026746b3b76aa5dabd2b
+DIST wf-shell-0.6.1.tar.xz 9014596 BLAKE2B 5256ceb8dc2b3dd4cf5d4503595c46b72bcde1dd4804a5871e225cee5b028ac69b02618d9c348fca4e21f2fd81b2be51fb0122126dd200dcdaeac894ec902c21 SHA512 d710cf703f5671bba01d056c7733724f90e6510a50e45a1a30cacde33a689c065335d802a3fd556cf9f8f0f420266ed2a8616706ecf5a68dcdf45a79876a4bcf
diff --git a/gui-apps/wf-shell/wf-shell-0.6.1.ebuild b/gui-apps/wf-shell/wf-shell-0.6.1.ebuild
new file mode 100644
index 000000000000..08f4995b15b2
--- /dev/null
+++ b/gui-apps/wf-shell/wf-shell-0.6.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A compiz like 3D wayland compositor"
+HOMEPAGE="https://github.com/WayfireWM/wf-shell"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
+else
+ SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+pulseaudio"
+
+DEPEND="
+ dev-cpp/gtkmm:3.0=[wayland]
+ dev-libs/gobject-introspection
+ gui-libs/gtk-layer-shell
+ >=gui-wm/wayfire-${PV%.*}
+ pulseaudio? ( media-sound/pulseaudio )
+"
+RDEPEND="${DEPEND}
+ gui-apps/wayland-logout
+"
+BDEPEND="
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"
+
+src_configure () {
+ local emesonargs=(
+ "$(meson_feature pulseaudio pulse)"
+ -Dwayland-logout=false
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/wf-shell/wf-shell-9999.ebuild b/gui-apps/wf-shell/wf-shell-9999.ebuild
index 94c26507f32a..08f4995b15b2 100644
--- a/gui-apps/wf-shell/wf-shell-9999.ebuild
+++ b/gui-apps/wf-shell/wf-shell-9999.ebuild
@@ -12,7 +12,7 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
else
- SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/${PV}/${P}.tar.xz"
+ SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/v${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm64 ~x86"
fi
@@ -23,13 +23,13 @@ IUSE="+pulseaudio"
DEPEND="
dev-cpp/gtkmm:3.0=[wayland]
dev-libs/gobject-introspection
- >=gui-libs/gtk-layer-shell-0.1
- >=gui-wm/wayfire-${PV}
+ gui-libs/gtk-layer-shell
+ >=gui-wm/wayfire-${PV%.*}
pulseaudio? ( media-sound/pulseaudio )
"
-
-RDEPEND="${DEPEND}"
-
+RDEPEND="${DEPEND}
+ gui-apps/wayland-logout
+"
BDEPEND="
dev-libs/wayland-protocols
virtual/pkgconfig
@@ -38,6 +38,7 @@ BDEPEND="
src_configure () {
local emesonargs=(
"$(meson_feature pulseaudio pulse)"
+ -Dwayland-logout=false
)
meson_src_configure
}