summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Hernández Hernández <leohdz172@proton.me>2023-10-11 10:46:46 -0600
committerArsen Arsenović <arsen@gentoo.org>2023-10-12 18:09:35 +0200
commita0df23139a24a8a6b91c6b281f45057379016db3 (patch)
treee0c0976daaf22d3a9ba72db5b8f4d5531eaa6d58 /gui-apps
parentgui-apps/foot-terminfo: add 1.16.0 (diff)
downloadgentoo-a0df23139a24a8a6b91c6b281f45057379016db3.tar.gz
gentoo-a0df23139a24a8a6b91c6b281f45057379016db3.tar.bz2
gentoo-a0df23139a24a8a6b91c6b281f45057379016db3.zip
gui-apps/foot: add 1.16.0
Signed-off-by: Leonardo Hernández Hernández <leohdz172@proton.me> Closes: https://github.com/gentoo/gentoo/pull/33303 Signed-off-by: Arsen Arsenović <arsen@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/foot/Manifest1
-rw-r--r--gui-apps/foot/foot-1.16.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/gui-apps/foot/Manifest b/gui-apps/foot/Manifest
index cd9204913b71..42dfb7d93d53 100644
--- a/gui-apps/foot/Manifest
+++ b/gui-apps/foot/Manifest
@@ -6,3 +6,4 @@ DIST foot-1.15.0.tar.gz 520829 BLAKE2B e86dba4c000ae3b290d207a2edef5e3b4240d27dd
DIST foot-1.15.1.tar.gz 523399 BLAKE2B 6e9296dcb8fd16fb77ec1e7a7668b46da31f83343f6b5fcafdb2514570ec7a356e1ba6308024331b66fdaca34eb86fd69dea6d5ab71a576ae13740a03d4245b7 SHA512 14605ba6e18b7ffc0961a3f00d275af2d885ec3d194123406d4fef21c6ec193c37ddee0a58f3a70853a72aabdbfc768bfc5fa1c516ad6cb669056c1c6dea990f
DIST foot-1.15.2.tar.gz 524743 BLAKE2B 7c6f573e733210f532238eb0d2385d49f61fcb531265ff1474b93cd092c8d860f27b11e6b36c506379d7874b9cc285825f56518817a2623fdde93b7c3d0e4fc6 SHA512 931231e0518950d3ac42625befab63ecc9a253bb870ea4c439d1110c40b31c15d049b9fc1e2a6282927737a9f6d7cd3278d42dffa6a57c3c1366e342e1e79622
DIST foot-1.15.3.tar.gz 524297 BLAKE2B 3909a2cd9b7df1dbc6305a14675494d65874d1af2ad550fcbc7fe4b33c1a2bb2287029922daedbea8c9bfa5a855e1dd5c01fa2011bc0f9ebddca8565a44da591 SHA512 c27fefd40518382a184c590d02eee69deecf665759e909de6f4a61234159df7a1b38061eb9fd776ed205f10a556d5bf7520f5515fa9cec22a683f2f25d7495f8
+DIST foot-1.16.0.tar.gz 529634 BLAKE2B b949e5e9097a9d5d2773e6bd48fb8e8535540984ffb43ebfcee2bf33ba5f313091c35f077880902ebc58e00d49ee8f40c24b830967ea26759d6e57e6692484c0 SHA512 de03a4f840fa21766d6d7e28cc5be266ce04fd92b5594d5c7d9cf7a14afd308cabf7f4f23c3bbd4a8c9ddb264211181a798cb1d4123961fe66a29bb44161ecc8
diff --git a/gui-apps/foot/foot-1.16.0.ebuild b/gui-apps/foot/foot-1.16.0.ebuild
new file mode 100644
index 000000000000..df30967e93ea
--- /dev/null
+++ b/gui-apps/foot/foot-1.16.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg systemd
+
+DESCRIPTION="Fast, lightweight and minimalistic Wayland terminal emulator"
+HOMEPAGE="https://codeberg.org/dnkl/foot"
+SRC_URI="https://codeberg.org/dnkl/foot/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="+grapheme-clustering test"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ dev-libs/wayland
+ media-libs/fcft
+ media-libs/fontconfig
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+ grapheme-clustering? (
+ dev-libs/libutf8proc:=
+ media-libs/fcft[harfbuzz]
+ )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ >=dev-libs/tllist-1.1.0
+ >=dev-libs/wayland-protocols-1.32
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ || (
+ >=sys-libs/ncurses-6.3[-minimal]
+ ~gui-apps/foot-terminfo-${PV}
+ )
+"
+BDEPEND="
+ app-text/scdoc
+ dev-util/wayland-scanner
+"
+
+src_prepare() {
+ default
+ # disable the systemd dep, we install the unit file manually
+ sed -i "s/systemd', required: false)$/', required: false)/" "${S}"/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature grapheme-clustering)
+ $(meson_use test tests)
+ -Dthemes=true
+ -Dime=true
+ -Dterminfo=disabled
+ )
+ meson_src_configure
+
+ sed 's|@bindir@|/usr/bin|g' "${S}"/foot-server.service.in > foot-server.service || die
+}
+
+src_install() {
+ local DOCS=( CHANGELOG.md README.md LICENSE )
+ meson_src_install
+
+ # foot unconditionally installs CHANGELOG.md, README.md and LICENSE.
+ # we handle this via DOCS and dodoc instead.
+ rm -r "${ED}/usr/share/doc/${PN}" || die
+ systemd_douserunit foot-server.service "${S}"/foot-server.socket
+}