summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Toth <gentoo@jonas-toth.eu>2022-01-15 18:27:18 +0100
committerIonen Wolkens <ionen@gentoo.org>2022-01-25 19:57:38 -0500
commita2527c38cc49edf1d3846d20ef1ae3ece3b2178d (patch)
tree516863ea328aae87687e0766a969b60a2e30a354 /gui-apps
parentnet-misc/ytfzf: drop 2.0 (diff)
downloadgentoo-a2527c38cc49edf1d3846d20ef1ae3ece3b2178d.tar.gz
gentoo-a2527c38cc49edf1d3846d20ef1ae3ece3b2178d.tar.bz2
gentoo-a2527c38cc49edf1d3846d20ef1ae3ece3b2178d.zip
gui-apps/waybar: version bump to 0.9.9
Updates `waybar` to version 0.9.9. With it comes a fix for `dev-libs/fmt` compatibility. Closes: https://bugs.gentoo.org/830749 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Jonas Toth <gentoo@jonas-toth.eu> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/waybar/Manifest1
-rw-r--r--gui-apps/waybar/waybar-0.9.9.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/gui-apps/waybar/Manifest b/gui-apps/waybar/Manifest
index 567c69c8b580..0a7f4edbb69c 100644
--- a/gui-apps/waybar/Manifest
+++ b/gui-apps/waybar/Manifest
@@ -1,3 +1,4 @@
DIST waybar-0.9.5.tar.gz 146094 BLAKE2B cd46e308d282df5ba6ce34417c0fe5468c188acb3c0f9bf5b2d4dd4c2c80547cab65172b4f4162c2dde0b78f68d15c8b79be74113cacd2610fd2a48299e14013 SHA512 0bbb9e898e205728fc564389927fec661a8dd6a9995a6c5d318f930f4527d6afd0be11a6b71dfa9aafb05c982e0f131e51eb0eec9a3e92c28f5cb04ff780fa8b
DIST waybar-0.9.7.tar.gz 150768 BLAKE2B 41dbcac30ffc42e04d565a590c1bce086271938936a05599bca6b74bac3fb2a8d1a4a4ddc5bec079dea6963eef8722c2c87a99c066de495caa163b1103a08095 SHA512 731b686235b1f0f94ce263e7ffa854f980fb8fccf30a0bd89e7aa0e1ca2c3fabd6d0df837bace6d6915d7a633500ed1f0497d012e082ca99fb32a78142b99279
DIST waybar-0.9.8.tar.gz 158869 BLAKE2B d5496986e3985747881cb8693b40d92e5c038a0ee55bf32e156efb67f02c46810cc80767635bd83837609b33855feced4f4f476deecbc47dfd43ef82700a87a2 SHA512 5c65b04cf0ae2e4cdff2b58c6b733a10a8b8d8acbb8f4f4519a0542be759fb6e84e46c323e4b8611ed25bda8bd322ee7a09cb697ed378e120841ce324021b104
+DIST waybar-0.9.9.tar.gz 181603 BLAKE2B ac0430fef2cc3be3a63ae2e27d6982cdea67ee800db8e9acda2bd8025114c8f065a87a164a787d2c82a00b81012fe2fad91e8adb1b51241bc722355b100fed86 SHA512 c219c55014726d9201031ef4448505de516507a74d840a3f733b1719ae0100d1e882580da8b1490158fff2c3003cf915e04bcdf8a55b757bdb845e29bf705ecd
diff --git a/gui-apps/waybar/waybar-0.9.9.ebuild b/gui-apps/waybar/waybar-0.9.9.ebuild
new file mode 100644
index 000000000000..fa2bf998afdc
--- /dev/null
+++ b/gui-apps/waybar/waybar-0.9.9.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Highly customizable Wayland bar for Sway and Wlroots based compositors"
+HOMEPAGE="https://github.com/Alexays/Waybar"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Alexays/${PN^}.git"
+else
+ SRC_URI="https://github.com/Alexays/${PN^}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+S="${WORKDIR}/${PN^}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="mpd network +popups pulseaudio sndio tray +udev wifi"
+
+BDEPEND="
+ >=app-text/scdoc-1.9.2
+ dev-util/gdbus-codegen
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-cpp/cairomm:0
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:3.0
+ dev-libs/glib:2
+ dev-libs/jsoncpp:=
+ dev-libs/libinput:=
+ dev-libs/libsigc++:2
+ >=dev-libs/libfmt-7.0.0:=
+ >=dev-libs/spdlog-1.8.5:=
+ dev-libs/date:=
+ dev-libs/wayland
+ dev-libs/wayland-protocols
+ gui-libs/wlroots:=
+ x11-libs/gtk+:3[wayland]
+ x11-libs/libxkbcommon
+ mpd? ( media-libs/libmpdclient )
+ network? ( dev-libs/libnl:3 )
+ popups? ( gui-libs/gtk-layer-shell )
+ pulseaudio? ( media-sound/pulseaudio )
+ sndio? ( media-sound/sndio:= )
+ tray? (
+ dev-libs/libdbusmenu[gtk3]
+ dev-libs/libappindicator
+ )
+ udev? ( virtual/libudev:= )
+ wifi? ( || ( sys-apps/util-linux net-wireless/rfkill ) )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature mpd)
+ $(meson_feature network libnl)
+ $(meson_feature popups gtk-layer-shell)
+ $(meson_feature pulseaudio)
+ $(meson_feature sndio)
+ $(meson_feature tray dbusmenu-gtk)
+ $(meson_feature udev libudev)
+ $(meson_feature wifi rfkill)
+ )
+ meson_src_configure
+}