summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-08-08 10:25:32 -0400
committerMatt Turner <mattst88@gentoo.org>2023-08-08 10:27:09 -0400
commitc1e445be70f85773bb39ebfdcebf8e3e3abec7cd (patch)
treee8b7f87b9e0204c8cb1e618cfd2775f0f8882e7c /gui-apps
parentgnome-extra/gnome-logs: Version bump to 45_beta (diff)
downloadgentoo-c1e445be70f85773bb39ebfdcebf8e3e3abec7cd.tar.gz
gentoo-c1e445be70f85773bb39ebfdcebf8e3e3abec7cd.tar.bz2
gentoo-c1e445be70f85773bb39ebfdcebf8e3e3abec7cd.zip
gui-apps/gnome-console: Version bump to 44.4
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/gnome-console/Manifest1
-rw-r--r--gui-apps/gnome-console/gnome-console-44.4.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/gui-apps/gnome-console/Manifest b/gui-apps/gnome-console/Manifest
index f0a9731cf13f..beb37bf3a109 100644
--- a/gui-apps/gnome-console/Manifest
+++ b/gui-apps/gnome-console/Manifest
@@ -1,2 +1,3 @@
DIST gnome-console-44.0.tar.xz 160764 BLAKE2B db8438cf90ae7d54a359faa6cdda15dfcf4f47ba350d7b62febe71b9ade39b52e2da8883705ef7e31886eca7aa2940a1a9d4813460ef8a04402b829bb21f5ba5 SHA512 c53435f303d1625730174f3ec36c554c2090a5e64796b03642bb2ccc7edc301219f324d929b77dd8b4bfe12553c089103b2b57b6e1062b504b0d0007c2079f28
+DIST gnome-console-44.4.tar.xz 160504 BLAKE2B d139108cabe647bf3cda5e30141187f7f579364b26c057f538299b87c08e370ca8f2f5739e8f5abc43a0bdb751751a9576b0165d1099c850772d664643f2dae0 SHA512 3fbd7c16638e829103e2dc517df6d68c7acbaca24f7f2af4a4bfeb79ec79944a98432dbdc778ecefd74fded0a701be179c09af95d099dbad79484d907ab923c6
DIST gnome-console-45.beta.tar.xz 169364 BLAKE2B b0834ce6b1398a0635097e29650ccce8dd0dd814e2efa1cb3d45986269e5491c031ef9c47113919fc26e424b04d2065f8c260befc786d62dc7deee09ee12c0b3 SHA512 1c9c9e34c39084c3182c6b03cee159b8e2a99e75acefc2882074d41fc62580e27acc12293c69b06a2cdb7e800a63b10b629f63d20ba52ce4bb493c1e09ffdaa6
diff --git a/gui-apps/gnome-console/gnome-console-44.4.ebuild b/gui-apps/gnome-console/gnome-console-44.4.ebuild
new file mode 100644
index 000000000000..057838f198a9
--- /dev/null
+++ b/gui-apps/gnome-console/gnome-console-44.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A simple user-friendly terminal emulator for the GNOME desktop"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/console"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.72:2
+ >=gui-libs/gtk-4.6:4
+ >=gui-libs/libadwaita-1.3_rc:1
+ >=gui-libs/vte-0.70.0:2.91-gtk4
+ gnome-base/libgtop:2=
+ >=dev-libs/libpcre2-10.32:0=
+ gnome-base/gsettings-desktop-schemas
+
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ dev-util/desktop-file-utils
+ dev-libs/appstream-glib
+ )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddevel=false
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}