summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-12-24 08:18:52 -0500
committerIonen Wolkens <ionen@gentoo.org>2021-12-24 09:26:38 -0500
commit3276a1eae562654e998dc39a9d2f0f85ca2eb6bb (patch)
tree16b09e2551e2c7a2b2487e7d228b386508fd0367 /gui-libs/egl-gbm/egl-gbm-1.1.0.ebuild
parentgui-libs/eglexternalplatform: EAPI7->8, adjust prefix sed (diff)
downloadgentoo-3276a1eae562654e998dc39a9d2f0f85ca2eb6bb.tar.gz
gentoo-3276a1eae562654e998dc39a9d2f0f85ca2eb6bb.tar.bz2
gentoo-3276a1eae562654e998dc39a9d2f0f85ca2eb6bb.zip
gui-libs/egl-gbm: initial import, version 1.1.0
This is libnvidia-egl-gbm.so previously provided only as a prebuilt by nvidia-drivers-495+, NVIDIA made the source available. Like egl-wayland this uses its own versioning and doesn't necessarily need to be in sync with drivers' version (albeit pinning may happen if there's major changes), so a separate package is more fitting. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'gui-libs/egl-gbm/egl-gbm-1.1.0.ebuild')
-rw-r--r--gui-libs/egl-gbm/egl-gbm-1.1.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/gui-libs/egl-gbm/egl-gbm-1.1.0.ebuild b/gui-libs/egl-gbm/egl-gbm-1.1.0.ebuild
new file mode 100644
index 000000000000..4d1b664b6bb7
--- /dev/null
+++ b/gui-libs/egl-gbm/egl-gbm-1.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="GBM EGL external platform library"
+HOMEPAGE="https://github.com/NVIDIA/egl-gbm"
+SRC_URI="https://github.com/NVIDIA/egl-gbm/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=media-libs/mesa-21.2[gbm(+)]
+ x11-libs/libdrm
+ !<x11-drivers/nvidia-drivers-495.46-r20[wayland(-)]"
+DEPEND="
+ ${RDEPEND}
+ >=media-libs/libglvnd-1.3.4
+ gui-libs/eglexternalplatform"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.0-werror.patch
+)
+
+src_install() {
+ meson_src_install
+
+ insinto /usr/share/egl/egl_external_platform.d
+ doins "${FILESDIR}"/15_nvidia_gbm.json
+}