summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-01-03 00:38:13 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-01-03 00:41:53 -0500
commit3b66263071ff363adbb55c04c746da5d559528c7 (patch)
treebea47391d6f51f4d20d7d8ae5ca015cbeb7c6703 /gui-libs/egl-gbm/egl-gbm-1.1.1.ebuild
parentsys-apps/ripgrep: keyword 14.0.3 for ~loong (diff)
downloadgentoo-3b66263071ff363adbb55c04c746da5d559528c7.tar.gz
gentoo-3b66263071ff363adbb55c04c746da5d559528c7.tar.bz2
gentoo-3b66263071ff363adbb55c04c746da5d559528c7.zip
gui-libs/egl-gbm: add 1.1.1
Not very different from the old snapshot, but has a few extra fixes from 2 months ago. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'gui-libs/egl-gbm/egl-gbm-1.1.1.ebuild')
-rw-r--r--gui-libs/egl-gbm/egl-gbm-1.1.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/gui-libs/egl-gbm/egl-gbm-1.1.1.ebuild b/gui-libs/egl-gbm/egl-gbm-1.1.1.ebuild
new file mode 100644
index 000000000000..e5d03bbb0309
--- /dev/null
+++ b/gui-libs/egl-gbm/egl-gbm-1.1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="GBM EGL external platform library"
+HOMEPAGE="https://github.com/NVIDIA/egl-gbm/"
+SRC_URI="https://github.com/NVIDIA/egl-gbm/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ media-libs/mesa[gbm(+)]
+ x11-libs/libdrm
+ !<x11-drivers/nvidia-drivers-495.46-r20[wayland(-)]
+"
+DEPEND="
+ ${RDEPEND}
+ gui-libs/eglexternalplatform
+ media-libs/libglvnd
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.0-werror.patch
+)
+
+src_install() {
+ meson_src_install
+
+ insinto /usr/share/egl/egl_external_platform.d
+ doins "${FILESDIR}"/15_nvidia_gbm.json
+}