summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Feldman <NP-Hardass@gentoo.org>2020-04-27 21:21:13 -0400
committerAdam Feldman <NP-Hardass@gentoo.org>2020-04-27 21:22:50 -0400
commitfdae499c98b04641348a9018fb5bff5ab69a7cef (patch)
tree3d1cc82228d5286c76759b989481206ee34e3121 /gui-libs/gtk-layer-shell/gtk-layer-shell-0.1.0-r1.ebuild
parentmedia-gfx/fontforge: fix docs build (diff)
downloadgentoo-fdae499c98b04641348a9018fb5bff5ab69a7cef.tar.gz
gentoo-fdae499c98b04641348a9018fb5bff5ab69a7cef.tar.bz2
gentoo-fdae499c98b04641348a9018fb5bff5ab69a7cef.zip
gui-libs/gtk-layer-shell: Fix #719866, missing dep
Closes: https://bugs.gentoo.org/719866 Package-Manager: Portage-2.3.96, Repoman-2.3.21 Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
Diffstat (limited to 'gui-libs/gtk-layer-shell/gtk-layer-shell-0.1.0-r1.ebuild')
-rw-r--r--gui-libs/gtk-layer-shell/gtk-layer-shell-0.1.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/gui-libs/gtk-layer-shell/gtk-layer-shell-0.1.0-r1.ebuild b/gui-libs/gtk-layer-shell/gtk-layer-shell-0.1.0-r1.ebuild
new file mode 100644
index 000000000000..7704b6464133
--- /dev/null
+++ b/gui-libs/gtk-layer-shell/gtk-layer-shell-0.1.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/wmww/${PN}"
+else
+ SRC_URI="https://github.com/wmww/${PN}/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Library to create desktop components for Wayland using the Layer Shell protocol"
+HOMEPAGE="https://github.com/wmww/gtk-layer-shell"
+
+LICENSE="MIT-with-advertising"
+SLOT="0"
+IUSE="examples gtk-doc"
+
+DEPEND="
+ >=x11-libs/gtk+-3.22.0:3[introspection,wayland]
+ >=dev-libs/wayland-1.10.0
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gtk-doc )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use examples)
+ $(meson_use gtk-doc docs)
+ )
+ meson_src_configure
+}