summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <floss@bsd.ac>2021-04-19 16:32:44 -0400
committerMatthew Thode <prometheanfire@gentoo.org>2021-04-19 15:38:34 -0500
commitef3dfe71841c72d6d5833fffce9c54c57977268a (patch)
tree7d7c967ca95cf5bb79c97a6a18064f6aae55bf50 /gui-libs/wlroots
parentsys-apps/util-linux: USE="ncurses" requires sys-apps/file for /bin/more (diff)
downloadgentoo-ef3dfe71841c72d6d5833fffce9c54c57977268a.tar.gz
gentoo-ef3dfe71841c72d6d5833fffce9c54c57977268a.tar.bz2
gentoo-ef3dfe71841c72d6d5833fffce9c54c57977268a.zip
gui-libs/wlroots: fix slot and live ebuild
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'gui-libs/wlroots')
-rw-r--r--gui-libs/wlroots/wlroots-0.13.0.ebuild2
-rw-r--r--gui-libs/wlroots/wlroots-9999.ebuild25
2 files changed, 8 insertions, 19 deletions
diff --git a/gui-libs/wlroots/wlroots-0.13.0.ebuild b/gui-libs/wlroots/wlroots-0.13.0.ebuild
index 1a25bccc0841..f370f34a6546 100644
--- a/gui-libs/wlroots/wlroots-0.13.0.ebuild
+++ b/gui-libs/wlroots/wlroots-0.13.0.ebuild
@@ -17,7 +17,7 @@ else
fi
LICENSE="MIT"
-SLOT="0/9999"
+SLOT="0/13"
IUSE="elogind icccm seatd systemd x11-backend X"
REQUIRED_USE="?? ( elogind systemd )"
diff --git a/gui-libs/wlroots/wlroots-9999.ebuild b/gui-libs/wlroots/wlroots-9999.ebuild
index 1a25bccc0841..9cf3f67c7412 100644
--- a/gui-libs/wlroots/wlroots-9999.ebuild
+++ b/gui-libs/wlroots/wlroots-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit fcaps meson
+inherit meson
DESCRIPTION="Pluggable, composable, unopinionated modules for building a Wayland compositor"
HOMEPAGE="https://github.com/swaywm/wlroots"
@@ -18,27 +18,24 @@ fi
LICENSE="MIT"
SLOT="0/9999"
-IUSE="elogind icccm seatd systemd x11-backend X"
-REQUIRED_USE="?? ( elogind systemd )"
+IUSE="x11-backend X"
DEPEND="
>=dev-libs/libinput-1.14.0:0=
>=dev-libs/wayland-1.19.0
>=dev-libs/wayland-protocols-1.17.0
media-libs/mesa[egl,gles2,gbm]
+ sys-auth/seatd:=
virtual/libudev
x11-libs/libdrm
x11-libs/libxkbcommon
x11-libs/pixman
- elogind? ( >=sys-auth/elogind-237 )
- icccm? ( x11-libs/xcb-util-wm )
- seatd? ( sys-auth/seatd:= )
- systemd? ( >=sys-apps/systemd-237 )
x11-backend? ( x11-libs/libxcb:0= )
X? (
x11-base/xorg-server[wayland]
x11-libs/libxcb:0=
x11-libs/xcb-util-image
+ x11-libs/xcb-util-wm
)
"
RDEPEND="
@@ -54,20 +51,12 @@ src_configure() {
# xcb-util-errors is not on Gentoo Repository (and upstream seems inactive?)
local emesonargs=(
"-Dxcb-errors=disabled"
- -Dxcb-icccm=$(usex icccm enabled disabled)
- -Dxwayland=$(usex X enabled disabled)
- -Dx11-backend=$(usex x11-backend enabled disabled)
"-Dexamples=false"
"-Dwerror=false"
- -Dlibseat=$(usex seatd enabled disabled)
+ "-Drenderers=gles2"
+ -Dxwayland=$(usex X enabled disabled)
+ -Dx11-backend=$(usex x11-backend enabled disabled)
)
- if use systemd; then
- emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=systemd")
- elif use elogind; then
- emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=elogind")
- else
- emesonargs+=("-Dlogind=disabled")
- fi
meson_src_configure
}