summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2020-09-13 14:27:57 +0200
committerAaron Bauman <bman@gentoo.org>2020-11-11 12:03:12 -0500
commit1a5bd9887d55435b50f1d427ccdd14a08a6e458f (patch)
tree3d8d0c683b6ff8e8a85a7825f670c78cf4bbd69e /gui-libs
parentsys-auth/seatd: New package (diff)
downloadgentoo-1a5bd9887d55435b50f1d427ccdd14a08a6e458f.tar.gz
gentoo-1a5bd9887d55435b50f1d427ccdd14a08a6e458f.tar.bz2
gentoo-1a5bd9887d55435b50f1d427ccdd14a08a6e458f.zip
gui-libs/wlroots: Add support for seatd
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/wlroots/metadata.xml1
-rw-r--r--gui-libs/wlroots/wlroots-9999.ebuild4
2 files changed, 4 insertions, 1 deletions
diff --git a/gui-libs/wlroots/metadata.xml b/gui-libs/wlroots/metadata.xml
index 25975bbdb159..07149597df5d 100644
--- a/gui-libs/wlroots/metadata.xml
+++ b/gui-libs/wlroots/metadata.xml
@@ -23,6 +23,7 @@
<use>
<flag name="elogind">Enable support for rootless session via elogind</flag>
<flag name="icccm">Use xcb-icccm (from <pkg>x11-libs/xcb-util-wm</pkg>) util library for improved Xwayland introspection</flag>
+ <flag name="seatd">Enable support for rootless session via <pkg>sys-auth/seatd</pkg></flag>
<flag name="x11-backend">Enable support for handling input/output devices through <pkg>x11-libs/libxcb</pkg></flag>
<flag name="X">Enable support for X11 applications (XWayland)</flag>
</use>
diff --git a/gui-libs/wlroots/wlroots-9999.ebuild b/gui-libs/wlroots/wlroots-9999.ebuild
index 6496ad0a75a2..72a4c104e4a6 100644
--- a/gui-libs/wlroots/wlroots-9999.ebuild
+++ b/gui-libs/wlroots/wlroots-9999.ebuild
@@ -18,7 +18,7 @@ fi
LICENSE="MIT"
SLOT="0/9999"
-IUSE="elogind icccm systemd x11-backend X"
+IUSE="elogind icccm seatd systemd x11-backend X"
REQUIRED_USE="?? ( elogind systemd )"
DEPEND="
@@ -32,6 +32,7 @@ DEPEND="
x11-libs/pixman
elogind? ( >=sys-auth/elogind-237 )
icccm? ( x11-libs/xcb-util-wm )
+ seatd? ( sys-auth/seatd:= )
systemd? ( >=sys-apps/systemd-237 )
x11-backend? ( x11-libs/libxcb:0= )
X? (
@@ -58,6 +59,7 @@ src_configure() {
-Dx11-backend=$(usex x11-backend enabled disabled)
"-Dexamples=false"
"-Dwerror=false"
+ -Dlibseat=$(usex seatd enabled disabled)
)
if use systemd; then
emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=systemd")