summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-01-07 23:14:06 -0500
committerMatt Turner <mattst88@gentoo.org>2021-01-07 23:15:21 -0500
commit393f25a28f758a156d040b2d176351e0038197eb (patch)
treeb25edae264a9008d0a150b5de681e1980271e767 /gui-libs
parentapp-admin/lastpass-cli: remove old (diff)
downloadgentoo-393f25a28f758a156d040b2d176351e0038197eb.tar.gz
gentoo-393f25a28f758a156d040b2d176351e0038197eb.tar.bz2
gentoo-393f25a28f758a156d040b2d176351e0038197eb.zip
gui-libs/libhandy: Version bump to 1.0.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/libhandy/Manifest1
-rw-r--r--gui-libs/libhandy/libhandy-1.0.3.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/gui-libs/libhandy/Manifest b/gui-libs/libhandy/Manifest
index 761fa6643579..96ca618977fb 100644
--- a/gui-libs/libhandy/Manifest
+++ b/gui-libs/libhandy/Manifest
@@ -1,2 +1,3 @@
DIST libhandy-1.0.2.tar.xz 388756 BLAKE2B c4995c5865378b133ba90125cd2c6c7500730be32b2426ccb323c878c22e556c0aad4eb0a5ab5f6ff936b3132a1717759af826e5bc0c9426b6f6972ac20f4f44 SHA512 411e016e1770ea83507a66e6e751f223304890cd193191c28cf751f8128dc5c98feb5342012596c10219e4da5a2445659395a0e7086d5c9990f7845b0406c685
+DIST libhandy-1.0.3.tar.xz 389068 BLAKE2B 2892103a672551f9a48a2f877568548fe771aeddbf156427baf03f8654488b5a0a8218f621366a47097030eb0ecf5abeb4f021d320046602cda0a028d91ec566 SHA512 cc304acc53e0819dce4931292e395ba44c1eb8630ebfa56390637bf376de226f4545906892967815c3e144423409b5a85e293568d3ed8069a6c4775307aeef4f
DIST libhandy-v0.0.13.tar.bz2 394811 BLAKE2B 318c226f20b4d8032e984dbd47b4634e828b922dcbc244e4f3f35b94c38f27ed38427196d553809bb1d6bfa7c4830db5d27701e3595cac8a05b58a27ba4a2472 SHA512 a0918c55c9ac14af223a83db542e7dc815d97c844d1f0830a1bee4bdcdf248d00d049fa90fd2be96265535a68d56de5143ddd9264b5e997a902ac9558d5096f3
diff --git a/gui-libs/libhandy/libhandy-1.0.3.ebuild b/gui-libs/libhandy/libhandy-1.0.3.ebuild
new file mode 100644
index 000000000000..1df7e54eddb4
--- /dev/null
+++ b/gui-libs/libhandy/libhandy-1.0.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org meson xdg vala virtualx
+
+DESCRIPTION="Building blocks for modern adaptive GNOME apps"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libhandy/"
+
+LICENSE="LGPL-2.1+"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="examples glade gtk-doc +introspection test +vala"
+REQUIRED_USE="vala? ( introspection )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.24.1:3[introspection?]
+ glade? ( dev-util/glade:3.10= )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.3 )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dprofiling=false # -pg passing
+ $(meson_feature introspection)
+ $(meson_use vala vapi)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use test tests)
+ $(meson_use examples)
+ $(meson_feature glade glade_catalog)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}