summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-03-14 10:51:26 -0300
committerMatt Turner <mattst88@gentoo.org>2023-03-17 22:28:45 -0400
commit69af77018d471de264412a2d3507e52cdf9b27e4 (patch)
treed3cb8674357ec7e2b8406403d7f9dacb8a204e3e /gui-libs
parentdev-libs/jsonrpc-glib: Version bump to 3.44.0 (diff)
downloadgentoo-69af77018d471de264412a2d3507e52cdf9b27e4.tar.gz
gentoo-69af77018d471de264412a2d3507e52cdf9b27e4.tar.bz2
gentoo-69af77018d471de264412a2d3507e52cdf9b27e4.zip
gui-libs/gtksourceview: Version bump to 5.8.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/gtksourceview/Manifest1
-rw-r--r--gui-libs/gtksourceview/gtksourceview-5.8.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/gui-libs/gtksourceview/Manifest b/gui-libs/gtksourceview/Manifest
index 95241e40126d..8f2030172826 100644
--- a/gui-libs/gtksourceview/Manifest
+++ b/gui-libs/gtksourceview/Manifest
@@ -1 +1,2 @@
DIST gtksourceview-5.6.2.tar.xz 1262272 BLAKE2B c2b2c9e8700d25472521188d034763f23eaa45ec02955bd045094c709169c89cfc9bc37bd66de7837fb61fa442123bb068c016cd183897f3ae49d05fa9212cf1 SHA512 82921af3e7eacf05b86310a9d9d96f8d21c215852f1bb2b38a9d4afe1fbb100b215761666a43a455fbd880d5d0b6bc1acccb8b3a4229bff55275b7978a69f077
+DIST gtksourceview-5.8.0.tar.xz 1253152 BLAKE2B 62806fbcced82fec3bdb3ec056dfe5d74db0c4cc039b6f0f18993872b9b082f1190698b0aca966bafc07c29d5ec7d37018c62e5142de0b426742cbe3ddac9f94 SHA512 370be5e8040f68eeef5fc6dec3e0ff9cbcf64a6ad162e228cddf07f6d493c762f37c89010073d4d850ec8c6ffa45c4697f5d9eb8c32de5fffc7ec97f44911d3b
diff --git a/gui-libs/gtksourceview/gtksourceview-5.8.0.ebuild b/gui-libs/gtksourceview/gtksourceview-5.8.0.ebuild
new file mode 100644
index 000000000000..ae20e4cb2fd6
--- /dev/null
+++ b/gui-libs/gtksourceview/gtksourceview-5.8.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson vala virtualx xdg
+
+DESCRIPTION="A text widget implementing syntax highlighting and other features"
+HOMEPAGE="https://wiki.gnome.org/Projects/GtkSourceView"
+
+LICENSE="LGPL-2.1+"
+SLOT="5"
+
+IUSE="gtk-doc +introspection sysprof +vala"
+REQUIRED_USE="
+ gtk-doc? ( introspection )
+ vala? ( introspection )
+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.72:2
+ >=gui-libs/gtk-4.6:4[introspection?]
+ >=dev-libs/libxml2-2.6:2
+ introspection? ( >=dev-libs/gobject-introspection-1.70.0:= )
+ >=dev-libs/fribidi-0.19.7
+ media-libs/fontconfig
+ x11-libs/pango[introspection?]
+ >=dev-libs/libpcre2-10.21:=[-recursion-limit(-)]
+ sysprof? ( dev-util/sysprof-capture:4 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? ( dev-util/gi-docgen )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ default
+ use vala && vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dinstall_tests=false
+ $(meson_feature introspection)
+ $(meson_use vala vapi)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use sysprof)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ # Tests fail in test-regex with libpcre2[recursion-limit] - https://gitlab.gnome.org/GNOME/gtksourceview/-/issues/255
+ # Ensured OK via USE dep, as it would mean issues in real usage for syntax highlighting as well
+ virtx meson_src_test --timeout-multiplier=2
+}
+
+src_install() {
+ meson_src_install
+
+ insinto /usr/share/${PN}-5/language-specs
+ newins "${FILESDIR}"/5-gentoo.lang gentoo.lang
+
+ if use gtk-doc ; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/html/ || die
+ mv "${ED}"/usr/share/doc/${PN}${SLOT} "${ED}"/usr/share/gtk-doc/html/ || die
+ fi
+}