summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-11-26 01:35:21 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-12-17 21:55:18 +0200
commit842ca343b1d29f30167c73937531a01df528f84d (patch)
tree34b93590dec8df5fed1e5f11537f0b31094ea0c3 /gui-libs
parentgui-wm/wayfire: add 0.8.0 (diff)
downloadgentoo-842ca343b1d29f30167c73937531a01df528f84d.tar.gz
gentoo-842ca343b1d29f30167c73937531a01df528f84d.tar.bz2
gentoo-842ca343b1d29f30167c73937531a01df528f84d.zip
gui-libs/wayfire-plugins-extra: add 0.8.0
Closes: https://bugs.gentoo.org/915795 Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/wayfire-plugins-extra/Manifest1
-rw-r--r--gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-0.8.0.ebuild38
-rw-r--r--gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-9999.ebuild20
3 files changed, 50 insertions, 9 deletions
diff --git a/gui-libs/wayfire-plugins-extra/Manifest b/gui-libs/wayfire-plugins-extra/Manifest
index 7331f5a979d8..978b46064ae5 100644
--- a/gui-libs/wayfire-plugins-extra/Manifest
+++ b/gui-libs/wayfire-plugins-extra/Manifest
@@ -1,2 +1,3 @@
DIST wayfire-plugins-extra-0.7.0.tar.xz 74312 BLAKE2B f72d706502499e4d467a4b59e10f66628024be1bab1c5e10c807758869c9b9e4aacbe426c2db0e3faa5ab166f7e4f4d0f1c345e205c6747a16a164745c6f0d74 SHA512 ff25a4685c88ca0129a2372b216166246cab072c2cb4f84eb7bd500db525bf5881bd7e54d0d888473d4aab0e5b33d2ee13eb7f788bb2a524e1e8e0c5efc1a6bd
DIST wayfire-plugins-extra-0.7.5.tar.xz 75136 BLAKE2B 7ffbb73f09175cc92f09b8a3f0493942741564278f95ff1d80066044b02ce4ceb925919ddb54fc6a37676b925d95ea7f93d09c6b0ccd448c6e9b821106d6e3ea SHA512 9cc816c3c727b0093fd15ef52dea215598b4c49ef96c098f53938c041b3908b30f4dd616be4b459b7382d630a47b36baf845c24de84f35670ba2912711205911
+DIST wayfire-plugins-extra-0.8.0.tar.xz 70324 BLAKE2B f8f46782e31f170eb566567f50d302df4db23fbeb29c71569624a7f79c2bbcfcf48b070e7b55bf1880a9cd02afe78783d6680c457e466d765eb0db72f4b1f61b SHA512 8105fea3d8405a88d8c872c1012dadfab55f987a8ff8401f5caeec155214727021cbc7cfaba71c5ee3bc869caf136dcd78c189921c2f41a938b8552962f1597c
diff --git a/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-0.8.0.ebuild b/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-0.8.0.ebuild
new file mode 100644
index 000000000000..245409005bf2
--- /dev/null
+++ b/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-0.8.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="extra plugins for wayfire"
+HOMEPAGE="https://github.com/WayfireWM/wayfire-plugins-extra"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/wayfire-plugins-extra.git"
+ SLOT="0/9999"
+else
+ SRC_URI="https://github.com/WayfireWM/wayfire-plugins-extra/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ SLOT="0/$(ver_cut 1-2)"
+fi
+
+LICENSE="MIT"
+
+# no tests
+RESTRICT="test"
+
+DEPEND="
+ dev-cpp/glibmm:2
+ dev-cpp/nlohmann_json
+ dev-libs/libevdev
+ dev-libs/wayland
+ gui-wm/wayfire:${SLOT}
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.12
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
diff --git a/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-9999.ebuild b/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-9999.ebuild
index e1eb8908ec68..245409005bf2 100644
--- a/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-9999.ebuild
+++ b/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-9999.ebuild
@@ -11,26 +11,28 @@ HOMEPAGE="https://github.com/WayfireWM/wayfire-plugins-extra"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/WayfireWM/wayfire-plugins-extra.git"
+ SLOT="0/9999"
else
SRC_URI="https://github.com/WayfireWM/wayfire-plugins-extra/releases/download/v${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm64 ~x86"
+ SLOT="0/$(ver_cut 1-2)"
fi
LICENSE="MIT"
-SLOT="0"
+
+# no tests
+RESTRICT="test"
DEPEND="
dev-cpp/glibmm:2
- x11-libs/pixman
- gnome-base/librsvg
- ~gui-libs/wlroots-9999:=
- ~gui-wm/wayfire-9999
- x11-libs/cairo
- x11-libs/pixman
+ dev-cpp/nlohmann_json
+ dev-libs/libevdev
+ dev-libs/wayland
+ gui-wm/wayfire:${SLOT}
"
RDEPEND="${DEPEND}"
-
BDEPEND="
- dev-libs/wayland-protocols
+ >=dev-libs/wayland-protocols-1.12
+ dev-util/wayland-scanner
virtual/pkgconfig
"