summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-08-23 23:07:49 +0300
committerMart Raudsepp <leio@gentoo.org>2020-08-23 23:08:02 +0300
commit8d8a3892c9a16b39689ab274474c12362e191d14 (patch)
treedab7b8159c11d2538ff935bdda4ff02717b185e8 /gui-libs
parentdev-util/smem: drop old version (diff)
downloadgentoo-8d8a3892c9a16b39689ab274474c12362e191d14.tar.gz
gentoo-8d8a3892c9a16b39689ab274474c12362e191d14.tar.bz2
gentoo-8d8a3892c9a16b39689ab274474c12362e191d14.zip
gui-libs/libhandy: fix USE=glade build against newer dev-util/glade
Closes: https://bugs.gentoo.org/737600 Package-Manager: Portage-2.3.103, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/libhandy/files/0.0.13-glade3.36-compat1.patch40
-rw-r--r--gui-libs/libhandy/files/0.0.13-glade3.36-compat2.patch56
-rw-r--r--gui-libs/libhandy/libhandy-0.0.13.ebuild4
3 files changed, 100 insertions, 0 deletions
diff --git a/gui-libs/libhandy/files/0.0.13-glade3.36-compat1.patch b/gui-libs/libhandy/files/0.0.13-glade3.36-compat1.patch
new file mode 100644
index 000000000000..13321778ff2f
--- /dev/null
+++ b/gui-libs/libhandy/files/0.0.13-glade3.36-compat1.patch
@@ -0,0 +1,40 @@
+From c5ada7063a68cc05ed1b783a9769557b8e2a83ed Mon Sep 17 00:00:00 2001
+From: Alberto Fanjul <albertofanjul@gmail.com>
+Date: Thu, 7 May 2020 12:43:51 +0200
+Subject: [PATCH 1/2] glade: Adapt to Glade 3.36 API changes
+
+Fixes https://source.puri.sm/Librem5/libhandy/issues/267.
+---
+ glade/glade-hdy-header-group.c | 2 +-
+ glade/glade-hdy-swipe-group.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/glade/glade-hdy-header-group.c b/glade/glade-hdy-header-group.c
+index be6a9de..aa83c6b 100644
+--- a/glade/glade-hdy-header-group.c
++++ b/glade/glade-hdy-header-group.c
+@@ -43,7 +43,7 @@ glade_hdy_header_group_read_widgets (GladeWidget *widget, GladeXmlNode *node)
+ string = widget_name;
+ } else if (widget_name != NULL) {
+ tmp =
+- g_strdup_printf ("%s%s%s", string, GPC_OBJECT_DELIMITER,
++ g_strdup_printf ("%s%s%s", string, GLADE_PROPERTY_DEF_OBJECT_DELIMITER,
+ widget_name);
+ string = (g_free (string), tmp);
+ g_free (widget_name);
+diff --git a/glade/glade-hdy-swipe-group.c b/glade/glade-hdy-swipe-group.c
+index 0b42798..ff909b0 100644
+--- a/glade/glade-hdy-swipe-group.c
++++ b/glade/glade-hdy-swipe-group.c
+@@ -45,7 +45,7 @@ glade_hdy_swipe_group_read_widgets (GladeWidget *widget,
+ string = widget_name;
+ } else if (widget_name != NULL) {
+ tmp =
+- g_strdup_printf ("%s%s%s", string, GPC_OBJECT_DELIMITER,
++ g_strdup_printf ("%s%s%s", string, GLADE_PROPERTY_DEF_OBJECT_DELIMITER,
+ widget_name);
+ string = (g_free (string), tmp);
+ g_free (widget_name);
+--
+2.20.1
+
diff --git a/gui-libs/libhandy/files/0.0.13-glade3.36-compat2.patch b/gui-libs/libhandy/files/0.0.13-glade3.36-compat2.patch
new file mode 100644
index 000000000000..a3b2f891499a
--- /dev/null
+++ b/gui-libs/libhandy/files/0.0.13-glade3.36-compat2.patch
@@ -0,0 +1,56 @@
+From 2fb8c6a62b52aa85266f1cf0e8cf6dfa1a7f194f Mon Sep 17 00:00:00 2001
+From: Adrien Plazas <kekun.plazas@laposte.net>
+Date: Mon, 11 May 2020 13:38:36 +0200
+Subject: [PATCH 2/2] glade: Support both 3.24 and 3.36
+
+leio: Backported to 0.0.13
+---
+ glade/glade-hdy-header-group.c | 9 +++++++++
+ glade/glade-hdy-swipe-group.c | 11 +++++++++++
+ 2 files changed, 20 insertions(+)
+
+diff --git a/glade/glade-hdy-header-group.c b/glade/glade-hdy-header-group.c
+index aa83c6b..bd620ad 100644
+--- a/glade/glade-hdy-header-group.c
++++ b/glade/glade-hdy-header-group.c
+@@ -14,6 +14,15 @@
+ #include <glib/gi18n-lib.h>
+ #include <gladeui/glade.h>
+
++/* Guess wether we are using a Glade version older than 3.36.
++ *
++ * If yes, redefine some symbols which got renamed.
++ */
++#ifndef GLADE_PROPERTY_DEF_OBJECT_DELIMITER
++#define GLADE_PROPERTY_DEF_OBJECT_DELIMITER GPC_OBJECT_DELIMITER
++#define glade_widget_action_get_def glade_widget_action_get_class
++#endif
++
+ #define GLADE_TAG_HEADERGROUP_WIDGETS "headerbars"
+ #define GLADE_TAG_HEADERGROUP_WIDGET "headerbar"
+
+diff --git a/glade/glade-hdy-swipe-group.c b/glade/glade-hdy-swipe-group.c
+index ff909b0..5b165a2 100644
+--- a/glade/glade-hdy-swipe-group.c
++++ b/glade/glade-hdy-swipe-group.c
+@@ -15,6 +15,17 @@
+ #include <glib/gi18n-lib.h>
+ #include <gladeui/glade.h>
+
++/* Guess wether we are using a Glade version older than 3.36.
++ *
++ * If yes, redefine some symbols which got renamed.
++ */
++#ifndef GLADE_PROPERTY_DEF_OBJECT_DELIMITER
++#define GLADE_PROPERTY_DEF_OBJECT_DELIMITER GPC_OBJECT_DELIMITER
++#define glade_widget_action_get_def glade_widget_action_get_class
++#endif
++
++#define GLADE_TAG_HEADERGROUP_WIDGETS "headerbars"
++#define GLADE_TAG_HEADERGROUP_WIDGET "headerbar"
+ #define PROP_SWIPEABLES "swipeables"
+ #define GLADE_TAG_SWIPEGROUP_SWIPEABLES "swipeables"
+ #define GLADE_TAG_SWIPEGROUP_SWIPEABLE "swipeable"
+--
+2.20.1
+
diff --git a/gui-libs/libhandy/libhandy-0.0.13.ebuild b/gui-libs/libhandy/libhandy-0.0.13.ebuild
index 4f69d327c067..07b2ca7fab24 100644
--- a/gui-libs/libhandy/libhandy-0.0.13.ebuild
+++ b/gui-libs/libhandy/libhandy-0.0.13.ebuild
@@ -37,6 +37,10 @@ BDEPEND="
app-text/docbook-xml-dtd:4.3 )
"
+PATCHES=(
+ "${FILESDIR}"/${PV}-glade3.36-compat{1,2}.patch
+)
+
src_prepare() {
use vala && vala_src_prepare
xdg_src_prepare