summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2023-04-15 19:20:14 +0000
committerJimi Huotari <chiitoo@gentoo.org>2023-04-18 01:06:14 +0300
commit94f19c8479fd2a3e21795c53d7b0a577d4cc7344 (patch)
tree9c1270a65a4191305547a9d539c01d4d6d2cc864 /gui-libs
parentx11-misc/screengrab: add 2.6.0 (diff)
downloadgentoo-94f19c8479fd2a3e21795c53d7b0a577d4cc7344.tar.gz
gentoo-94f19c8479fd2a3e21795c53d7b0a577d4cc7344.tar.bz2
gentoo-94f19c8479fd2a3e21795c53d7b0a577d4cc7344.zip
gui-libs/xdg-desktop-portal-lxqt: add 0.4.0
Signed-off-by: Michael Vetter <jubalh@iodoru.org> Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/xdg-desktop-portal-lxqt/Manifest1
-rw-r--r--gui-libs/xdg-desktop-portal-lxqt/xdg-desktop-portal-lxqt-0.4.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/gui-libs/xdg-desktop-portal-lxqt/Manifest b/gui-libs/xdg-desktop-portal-lxqt/Manifest
index 2f70e9f665fb..7ebbd9696bbb 100644
--- a/gui-libs/xdg-desktop-portal-lxqt/Manifest
+++ b/gui-libs/xdg-desktop-portal-lxqt/Manifest
@@ -1 +1,2 @@
DIST xdg-desktop-portal-lxqt-0.3.0.tar.xz 16012 BLAKE2B a7b326e4ee7dd089b44e101c2be3625d6e81f229d7a6719ebb1743bc586f6c52044792e7eec10ce6821f60119f4a891cc640ab44f494ba4322cac03dcefb7b00 SHA512 13ffa6fc53eec53805b23a533bcccbe786482c1d587da0ab055ba4275bc46bbb545073749899f13164b740348b8736860f364710cc1b5d980352288f6ffc12d7
+DIST xdg-desktop-portal-lxqt-0.4.0.tar.xz 16024 BLAKE2B 2f362f9ddff42d68dfe69bcebd229566fe396a5a14d9ee9f1650706a34a98f31291a9901ef7121a976c679481192959d785ca8c8401bf8b2839dd18e42eee6bc SHA512 9295da6dc9370e01a48729848d9d19c9afea980335fb1cefeb91abf34b12d53579d876ccc952e2ef1440e10f0937b9c4a02d2c8473c9cad812da0388bfcacbe1
diff --git a/gui-libs/xdg-desktop-portal-lxqt/xdg-desktop-portal-lxqt-0.4.0.ebuild b/gui-libs/xdg-desktop-portal-lxqt/xdg-desktop-portal-lxqt-0.4.0.ebuild
new file mode 100644
index 000000000000..3867617ce7ef
--- /dev/null
+++ b/gui-libs/xdg-desktop-portal-lxqt/xdg-desktop-portal-lxqt-0.4.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="$(ver_cut 1-2)"
+
+inherit cmake
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal using Qt/KF5/libfm-qt"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+BDEPEND=">=dev-util/lxqt-build-tools-0.13.0"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ kde-frameworks/kwindowsystem:5
+ >=x11-libs/libfm-qt-1.3:=
+"
+RDEPEND="${DEPEND}
+ sys-apps/xdg-desktop-portal
+"