summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-08-16 23:38:54 +0300
committerMart Raudsepp <leio@gentoo.org>2020-08-17 00:01:23 +0300
commit97c9527f83bb04ef0b785c26687e13b0630e8af6 (patch)
tree8fb3c940e24e3b6086b8bad7ac58ac92c9fb5ffc /gui-libs
parentapp-portage/esearch: Update PYTHON_COMPAT and EAPI for 9999 (diff)
downloadgentoo-97c9527f83bb04ef0b785c26687e13b0630e8af6.tar.gz
gentoo-97c9527f83bb04ef0b785c26687e13b0630e8af6.tar.bz2
gentoo-97c9527f83bb04ef0b785c26687e13b0630e8af6.zip
gui-libs/tepl: bump to 4.4.0
Package-Manager: Portage-2.3.103, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/tepl/Manifest1
-rw-r--r--gui-libs/tepl/tepl-4.4.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/gui-libs/tepl/Manifest b/gui-libs/tepl/Manifest
index de22d78aa976..0c6186612993 100644
--- a/gui-libs/tepl/Manifest
+++ b/gui-libs/tepl/Manifest
@@ -1 +1,2 @@
DIST tepl-4.2.1.tar.xz 464120 BLAKE2B 74146cdf837923ab1a8e843e189bd83b2c7d7ae9cbf03ce4f3dbbbbfee1f47dffcda537ad8133cdf1b4efd747f0ee60092ddab029a67282b71fdc52d51564dc4 SHA512 c1b848cf1d336efdc2971e16060baf721e9019e6e6827bd755235c9dd37ae47803343e51888d9dd5817b6127bb1ba05a19d4a1be0caab9d2de125bc0cd8175a7
+DIST tepl-4.4.0.tar.xz 466576 BLAKE2B fe9d9c625a3febe6fc71e5972b864b0d732b7f75bcc114a391d7f94b2fc242fe7c5199e61d5a69a8ceccb845fffcf830d6071adb1ecda5e223d453d029ed3398 SHA512 2050c28f9564034bea7c44d3fa27784ab87503c2db6cf35e6389c40ca78722b092fbc52df5fdfc85cc1e39a9dc3c0e30fa7993fb63411b0240f3a6ac9607c282
diff --git a/gui-libs/tepl/tepl-4.4.0.ebuild b/gui-libs/tepl/tepl-4.4.0.ebuild
new file mode 100644
index 000000000000..43b7ec06cd1e
--- /dev/null
+++ b/gui-libs/tepl/tepl-4.4.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2 virtualx
+
+DESCRIPTION="GtkSourceView-based text editors and IDE helper library"
+HOMEPAGE="https://wiki.gnome.org/Projects/Gtef"
+
+LICENSE="LGPL-2.1+"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.52:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ >=x11-libs/gtksourceview-4.0:4[introspection?]
+ >=gui-libs/amtk-5.0:5[introspection?]
+ >=dev-libs/libxml2-2.5:2
+ app-i18n/uchardet
+ introspection? ( >=dev-libs/gobject-introspection-1.42:= )
+"
+DEPEND="${DEPEND}
+ >=sys-devel/gettext-0.19.6
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.25
+ virtual/pkgconfig
+"
+
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ # requires running gvfs-metadata
+ sed -e 's:\(g_test_add_func.*/file/load_save_metadata_sync.*\):/*\1*/:' \
+ -e 's:\(g_test_add_func.*/file/load_save_metadata_async.*\):/*\1*/:' \
+ -e 's:\(g_test_add_func.*/file/set_without_load.*\):/*\1*/:' \
+ -i testsuite/test-file-metadata.c || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # valgrind checks not ran by default and require suppression files not in locations where they'd be installed by other packages
+ gnome2_src_configure \
+ --enable-gvfs-metadata \
+ --disable-valgrind \
+ $(use_enable introspection)
+}
+
+src_test() {
+ virtx emake check
+}