summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-05-27 22:27:43 +0200
committerPacho Ramos <pacho@gentoo.org>2022-05-27 22:27:43 +0200
commita1b2f5621486e3b7ab227591232ab46f45776a74 (patch)
treef6aaff82d771ac5d072a11240a4bb1ad8b736cab /gui-libs
parentgnome-base/gnome-control-center: add 42.2 (diff)
downloadgentoo-a1b2f5621486e3b7ab227591232ab46f45776a74.tar.gz
gentoo-a1b2f5621486e3b7ab227591232ab46f45776a74.tar.bz2
gentoo-a1b2f5621486e3b7ab227591232ab46f45776a74.zip
gui-libs/tepl: add 6.0.2
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/tepl/Manifest1
-rw-r--r--gui-libs/tepl/tepl-6.0.2.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/gui-libs/tepl/Manifest b/gui-libs/tepl/Manifest
index 39ca7fb9fe22..a5cb269ba797 100644
--- a/gui-libs/tepl/Manifest
+++ b/gui-libs/tepl/Manifest
@@ -1,3 +1,4 @@
DIST tepl-5.0.1.tar.xz 126068 BLAKE2B 2c3038326660f6326c5030cb944f8cee885b794a481f6d8f1b5d87a8ea7121ded381d28b36246a99b57bbea5fd9e6d2d4f65f9dfc54d8154ee8aabbccd7e3cb5 SHA512 f363d182185976447d235cf1201148e5201cdabd1fa8b88d7a763a965896f87bd222a0161c11e93662afaf4e474bbd0308643d28559aadc27b9d48974f4c458d
DIST tepl-6.0.1.tar.xz 142884 BLAKE2B 7da51ecd3b1a74fc22e98020ad6b73c98524c97384c26c9cc0ef0a972214afcbb8c2bd4976904cea91784f815e626c501cf68d85d876b764af3b8bd182848694 SHA512 31d7a6e5f66e66f380f780089c13ccb938052237acf514713a731b374afd6871fb8d0685db2137fa2c62548dd3ae85a198ce3bfc3148ec30feb0cb0f10c78114
+DIST tepl-6.0.2.tar.xz 142916 BLAKE2B 584d4ccec446f94590020e569f1a2b28d4b10a2452479c2c521c05927a094d01b28d81e2271dc8f4e1aa0a66976df64cead357f5487f78944c20ceca5c542742 SHA512 8b12418ba9e18a3aa1772692d196583353d98d73a007b35d93d2c605efceb5064e556968e5612f326f6b447ced0cdd66c130b6840c98ec067e1ba7da930fa4b4
DIST tepl-6.00.0.tar.xz 141908 BLAKE2B 200693a8cf760d18e1c53647abb8156f7e067557b4cefbd05b03c5a3ec83c3c5807ab93e0464178b68fc9f2572c3175fbf9355f4131df1fe7f79b5e2deb3961e SHA512 e36877b9f33943715a50546d82ed61e65fc07b71dca2c85ff350a305767e96eda74dc14f30b2a430e14deacd4ee8d49697fe01df1f5023afab3747e5e9c95e2e
diff --git a/gui-libs/tepl/tepl-6.0.2.ebuild b/gui-libs/tepl/tepl-6.0.2.ebuild
new file mode 100644
index 000000000000..7b36b106c694
--- /dev/null
+++ b/gui-libs/tepl/tepl-6.0.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson virtualx
+
+DESCRIPTION="GtkSourceView-based text editors and IDE helper library"
+HOMEPAGE="https://gitlab.gnome.org/swilmet/tepl"
+
+LICENSE="LGPL-3+"
+SLOT="6"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+introspection gtk-doc"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.62:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ >=x11-libs/gtksourceview-4.0:4[introspection?]
+ >=gui-libs/amtk-5.0:5[introspection?]
+ dev-libs/icu:=
+ introspection? ( >=dev-libs/gobject-introspection-1.42:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.25
+ app-text/docbook-xml-dtd:4.3
+ )
+ >=sys-devel/gettext-0.19.6
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection gobject_introspection)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}