summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-06-21 16:56:23 -0700
committerMatt Turner <mattst88@gentoo.org>2021-06-21 16:59:14 -0700
commitc77e2a7514123b41566cd22e7fe2472f54fa0d55 (patch)
tree81caa98cc80aad7b80dea7c28e19df8e176c8ec5 /gui-libs
parentapp-crypt/dehydrated: keyword 0.7.0 for ~riscv (diff)
downloadgentoo-c77e2a7514123b41566cd22e7fe2472f54fa0d55.tar.gz
gentoo-c77e2a7514123b41566cd22e7fe2472f54fa0d55.tar.bz2
gentoo-c77e2a7514123b41566cd22e7fe2472f54fa0d55.zip
gui-libs/libhandy: Version bump to 1.2.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/libhandy/Manifest1
-rw-r--r--gui-libs/libhandy/libhandy-1.2.3.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/gui-libs/libhandy/Manifest b/gui-libs/libhandy/Manifest
index 0f4a0f27db15..39cc287d6007 100644
--- a/gui-libs/libhandy/Manifest
+++ b/gui-libs/libhandy/Manifest
@@ -1,2 +1,3 @@
DIST libhandy-1.2.2.tar.xz 488508 BLAKE2B 1b764c90710de8a7960308b6441657799e6c3a12de9688f720748ca57653f6592fb4ba9f75841d76ae477af7c1709dc4f303658cc543c8de3f6f64d1de7d03cf SHA512 2135d3e15931fa143698de9200803c90e93c87b82c96b4fff90b75075c218a8ef2f69a26210bda8c10fb7195f115b11b804bb6de0b2f65cd464a7cefe35d0af4
+DIST libhandy-1.2.3.tar.xz 491024 BLAKE2B b15e4b12135230ce6e588e005f55edada001abaa3fbdcf2f05b5e05f364beaa8983239f3a562b8600fc07edd6b6b7e834d42a06ec1ec626d7a43d6634ba93d0e SHA512 20ed6708bb517c81d9b8520c522555d7cdaf36f19dd29603a4f86d6d47ec2552af8874605b1866eb634d25afd0a2c18690cb1be6eafce81cac7857890388799e
DIST libhandy-v0.0.13.tar.bz2 394811 BLAKE2B 318c226f20b4d8032e984dbd47b4634e828b922dcbc244e4f3f35b94c38f27ed38427196d553809bb1d6bfa7c4830db5d27701e3595cac8a05b58a27ba4a2472 SHA512 a0918c55c9ac14af223a83db542e7dc815d97c844d1f0830a1bee4bdcdf248d00d049fa90fd2be96265535a68d56de5143ddd9264b5e997a902ac9558d5096f3
diff --git a/gui-libs/libhandy/libhandy-1.2.3.ebuild b/gui-libs/libhandy/libhandy-1.2.3.ebuild
new file mode 100644
index 000000000000..1df7e54eddb4
--- /dev/null
+++ b/gui-libs/libhandy/libhandy-1.2.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org meson xdg vala virtualx
+
+DESCRIPTION="Building blocks for modern adaptive GNOME apps"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libhandy/"
+
+LICENSE="LGPL-2.1+"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="examples glade gtk-doc +introspection test +vala"
+REQUIRED_USE="vala? ( introspection )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.24.1:3[introspection?]
+ glade? ( dev-util/glade:3.10= )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.3 )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dprofiling=false # -pg passing
+ $(meson_feature introspection)
+ $(meson_use vala vapi)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use test tests)
+ $(meson_use examples)
+ $(meson_feature glade glade_catalog)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}