summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-09-09 21:30:09 -0400
committerPiotr Karbowski <slashbeast@gentoo.org>2021-01-30 20:17:42 +0100
commitc78bee32adb057ac965b7f60f46980951cfa44bc (patch)
tree427d23cc20481fb66536128c33409d7ac5df2ee8 /gui-libs
parentsys-kernel/gentoo-sources: 4.4.254 (diff)
downloadgentoo-c78bee32adb057ac965b7f60f46980951cfa44bc.tar.gz
gentoo-c78bee32adb057ac965b7f60f46980951cfa44bc.tar.bz2
gentoo-c78bee32adb057ac965b7f60f46980951cfa44bc.zip
gui-libs/display-manager-init: refactor init files out of xorg-server
Closes: https://bugs.gentoo.org/730644 Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/display-manager-init/display-manager-init-1.0.ebuild37
-rw-r--r--gui-libs/display-manager-init/files/display-manager-setup.initd13
-rw-r--r--gui-libs/display-manager-init/files/display-manager.confd13
-rw-r--r--gui-libs/display-manager-init/files/display-manager.initd234
-rw-r--r--gui-libs/display-manager-init/files/startDM29
-rw-r--r--gui-libs/display-manager-init/files/xdm.initd13
-rw-r--r--gui-libs/display-manager-init/metadata.xml8
7 files changed, 347 insertions, 0 deletions
diff --git a/gui-libs/display-manager-init/display-manager-init-1.0.ebuild b/gui-libs/display-manager-init/display-manager-init-1.0.ebuild
new file mode 100644
index 000000000000..576a0a7c887c
--- /dev/null
+++ b/gui-libs/display-manager-init/display-manager-init-1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="RC init files for starting display and login managers"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:X11"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+S="${FILESDIR}"
+
+RDEPEND="
+ sys-apps/gentoo-functions
+ !<=sys-apps/sysvinit-2.98
+ !<=x11-apps/xinit-1.4.1
+ !<=x11-base/xorg-server-1.20.10
+"
+
+src_install() {
+ newinitd "${FILESDIR}"/display-manager-setup.initd display-manager-setup
+ newinitd "${FILESDIR}"/display-manager.initd display-manager
+ newinitd "${FILESDIR}"/xdm.initd xdm
+ newconfd "${FILESDIR}"/display-manager.confd display-manager
+ exeinto /usr/bin
+ doexe "${FILESDIR}"/startDM
+ # backwards compatibility
+ dosym "${ESYSROOT}"/usr/bin/startDM /etc/X11/startDM.sh
+}
+
+pkg_preinst() {
+ if [[ ${REPLACING_VERSIONS} == "" && -f "${EROOT}"/etc/conf.d/xdm && ! -f "${EROOT}"/etc/conf.d/display-manager ]]; then
+ mv "${EROOT}"/etc/conf.d/{xdm,display-manager} || die
+ fi
+}
diff --git a/gui-libs/display-manager-init/files/display-manager-setup.initd b/gui-libs/display-manager-init/files/display-manager-setup.initd
new file mode 100644
index 000000000000..05feeee84ae6
--- /dev/null
+++ b/gui-libs/display-manager-init/files/display-manager-setup.initd
@@ -0,0 +1,13 @@
+#!/sbin/openrc-run
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need localmount
+}
+
+start() {
+ if get_bootparam "nogui" ; then
+ touch /run/.nogui
+ fi
+}
diff --git a/gui-libs/display-manager-init/files/display-manager.confd b/gui-libs/display-manager-init/files/display-manager.confd
new file mode 100644
index 000000000000..25d57e923c45
--- /dev/null
+++ b/gui-libs/display-manager-init/files/display-manager.confd
@@ -0,0 +1,13 @@
+# We always try and start the DM on a static VT. The various DMs normally
+# default to using VT7. If you wish to use the display-manager init
+# script, then you should ensure that the VT checked is the same VT your
+# DM wants to use.
+# We do this check to ensure that you haven't accidentally configured
+# something to run on the VT in your /etc/inittab file so that
+# you don't get a dead keyboard.
+CHECKVT=7
+
+# What display manager do you use ?
+# [ xdm | greetd | gdm | sddm | gpe | lightdm | entrance ]
+# NOTE: If this is set in /etc/rc.conf, that setting will override this one.
+DISPLAYMANAGER="xdm"
diff --git a/gui-libs/display-manager-init/files/display-manager.initd b/gui-libs/display-manager-init/files/display-manager.initd
new file mode 100644
index 000000000000..e650df9600e8
--- /dev/null
+++ b/gui-libs/display-manager-init/files/display-manager.initd
@@ -0,0 +1,234 @@
+#!/sbin/openrc-run
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License, v2
+
+# This is here to serve as a note to myself, and future developers.
+#
+# Any Display manager (gdm,kdm,xdm) has the following problem: if
+# it is started before any getty, and no vt is specified, it will
+# usually run on vt2. When the getty on vt2 then starts, and the
+# DM is already started, the getty will take control of the keyboard,
+# leaving us with a "dead" keyboard.
+#
+# Resolution: add the following line to /etc/inittab
+#
+# x:a:once:/usr/bin/startDM
+#
+# and have /usr/bin/startDM start the DM in daemon mode if
+# a lock is present (with the info of what DM should be started),
+# else just fall through.
+#
+# How this basically works, is the "a" runlevel is a additional
+# runlevel that you can use to fork processes with init, but the
+# runlevel never gets changed to this runlevel. Along with the "a"
+# runlevel, the "once" key word means that startDM will only be
+# run when we specify it to run, thus eliminating respawning
+# startDM when "display-manager" is not added to the default
+# runlevel, as was done previously.
+#
+# This script then just calls "telinit a", and init will run
+# /usr/bin/startDM after the current runlevel completes (this
+# script should only be added to the actual runlevel the user is
+# using).
+#
+# Martin Schlemmer
+# aka Azarah
+# 04 March 2002
+
+depend() {
+ need localmount display-manager-setup
+
+ # this should start as early as possible
+ # we can't do 'before *' as that breaks it
+ # (#139824) Start after ypbind and autofs for network authentication
+ # (#145219 #180163) Could use lirc mouse as input device
+ # (#70689 comment #92) Start after consolefont to avoid display corruption
+ # (#291269) Start after quota, since some dm need readable home
+ # (#390609) gdm-3 will fail when dbus is not running
+ # (#366753) starting keymaps after X causes problems
+ after bootmisc consolefont modules netmount
+ after readahead-list ypbind autofs openvpn gpm lircmd
+ after quota keymaps
+ before alsasound
+
+ # Start before GUI
+ use dbus xfs
+}
+
+setup_dm() {
+ local MY_XDM
+
+ MY_XDM=$(echo "${DISPLAYMANAGER}" | tr '[:upper:]' '[:lower:]')
+
+ NAME=
+ case "${MY_XDM}" in
+ kdm|kde)
+ # Load our root path from profile.env
+ # Needed for kdm
+ PATH=${PATH}:$(. /etc/profile.env; echo "${ROOTPATH}")
+ EXE=/usr/bin/kdm
+ PIDFILE=/run/kdm.pid
+ ;;
+ entrance*)
+ EXE=/usr/sbin/entrance
+ PIDFILE=/run/entrance.pid
+ ;;
+ gdm|gnome)
+ # gdm-3 and above has different paths
+ if [ -f /usr/sbin/gdm ]; then
+ EXE=/usr/sbin/gdm
+ PIDFILE=/run/gdm/gdm.pid
+ START_STOP_ARGS="--background"
+ AUTOCLEAN_CGROUP="yes"
+ else
+ EXE=/usr/bin/gdm
+ PIDFILE=/run/gdm.pid
+ fi
+ [ "${RC_UNAME}" != "Linux" ] && NAME=gdm-binary
+ ;;
+ greetd)
+ EXE=/usr/bin/greetd
+ PIDFILE=/run/greetd.pid
+ START_STOP_ARGS="-m --background"
+ ;;
+ wdm)
+ EXE=/usr/bin/wdm
+ PIDFILE=
+ ;;
+ gpe)
+ EXE=/usr/bin/gpe-dm
+ PIDFILE=/run/gpe-dm.pid
+ ;;
+ lxdm)
+ EXE=/usr/sbin/lxdm-binary
+ PIDFILE=/run/lxdm.pid
+ START_STOP_ARGS="--background"
+ ;;
+ lightdm)
+ EXE=/usr/sbin/lightdm
+ PIDFILE=/run/lightdm.pid
+ START_STOP_ARGS="--background"
+ ;;
+ sddm)
+ EXE="/usr/bin/sddm"
+ START_STOP_ARGS="-m --background"
+ PIDFILE=/run/sddm.pid
+ ;;
+ *)
+ # first find out if there is such executable
+ EXE="$(command -v ${MY_XDM} 2>/dev/null)"
+ PIDFILE="/run/${MY_XDM}.pid"
+
+ # warn user that they are doing sick things if the exe was not found
+ if [ -z "${EXE}" ]; then
+ echo "ERROR: Your XDM value is invalid."
+ echo " No ${MY_XDM} executable could be found on your system."
+ fi
+ ;;
+ esac
+
+ if ! [ -x "${EXE}" ]; then
+ EXE=/usr/bin/xdm
+ PIDFILE=/run/xdm.pid
+ if ! [ -x "/usr/bin/xdm" ]; then
+ echo "ERROR: Please set your DISPLAYMANAGER variable in /etc/conf.d/xdm,"
+ echo " or install x11-apps/xdm package"
+ eend 255
+ fi
+ fi
+}
+
+# Check to see if something is defined on our VT
+vtstatic() {
+ if [ -e /etc/inittab ] ; then
+ grep -Eq "^[^#]+.*\<tty$1\>" /etc/inittab
+ elif [ -e /etc/ttys ] ; then
+ grep -q "^ttyv$(($1 - 1))" /etc/ttys
+ else
+ return 1
+ fi
+}
+
+start() {
+ local EXE NAME PIDFILE AUTOCLEAN_CGROUP
+ setup_dm
+
+ if [ -f /run/.nogui ]; then
+ einfo "Skipping ${EXE##*/}, /run/.nogui found or 'nogui' bootparam passed."
+ rm /run/.nogui
+ return 0
+ fi
+
+ ebegin "Setting up ${EXE##*/}"
+
+ # save the prefered DM
+ save_options "service" "${EXE}"
+ save_options "name" "${NAME}"
+ save_options "pidfile" "${PIDFILE}"
+ save_options "start_stop_args" "${START_STOP_ARGS}"
+ save_options "autoclean_cgroup" "${AUTOCLEAN_CGROUP:-no}"
+
+ if [ -n "${CHECKVT-y}" ] ; then
+ if vtstatic "${CHECKVT:-7}" ; then
+ if [ -x /sbin/telinit ] && [ "${SOFTLEVEL}" != "BOOT" ] && [ "${RC_SOFTLEVEL}" != "BOOT" ]; then
+ ewarn "Something is already defined on VT ${CHECKVT:-7}, will start X later"
+ telinit a >/dev/null 2>&1
+ return 0
+ else
+ eerror "Something is already defined on VT ${CHECKVT:-7}, not starting"
+ return 1
+ fi
+ fi
+ fi
+
+ /usr/bin/startDM
+ eend 0
+}
+
+stop() {
+ local curvt retval
+
+ retval=0
+ if [ -t 0 ]; then
+ if type fgconsole >/dev/null 2>&1; then
+ curvt=$(fgconsole 2>/dev/null)
+ else
+ curvt=$(tty)
+ case "${curvt}" in
+ /dev/ttyv[0-9]*) curvt=${curvt#/dev/ttyv} ;;
+ *) curvt= ;;
+ esac
+ fi
+ fi
+ local myexe myname mypidfile myservice
+ myexe=$(get_options "service")
+ myname=$(get_options "name")
+ mypidfile=$(get_options "pidfile")
+ myservice=${myexe##*/}
+ yesno "${rc_cgroup_cleanup:-no}" || rc_cgroup_cleanup=$(get_options "autoclean_cgroup")
+
+ [ -z "${myexe}" ] && return 0
+
+ ebegin "Stopping ${myservice}"
+
+ if start-stop-daemon --quiet --test --stop --exec "${myexe}" 2>/dev/null; then
+ start-stop-daemon --stop --exec "${myexe}" --retry TERM/5/TERM/5 \
+ "${mypidfile:+--pidfile}" "${mypidfile}" \
+ "${myname:+--name}" "${myname}"
+ retval=${?}
+ fi
+
+ # switch back to original vt
+ if [ -n "${curvt}" ]; then
+ if type chvt >/dev/null 2>&1; then
+ chvt "${curvt}"
+ else
+ vidcontrol -s "$((curvt + 1))"
+ fi
+ fi
+
+ eend ${retval} "Error stopping ${myservice}"
+ return ${retval}
+}
+
+# vim: set ts=4 :
diff --git a/gui-libs/display-manager-init/files/startDM b/gui-libs/display-manager-init/files/startDM
new file mode 100644
index 000000000000..976d1dd2d56d
--- /dev/null
+++ b/gui-libs/display-manager-init/files/startDM
@@ -0,0 +1,29 @@
+#!/bin/sh
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License, v2
+
+# We need to source /etc/profile.env for stuff like $LANG to work
+# bug #10190.
+. /etc/profile.env
+
+# need eerror
+. /lib/gentoo/functions.sh
+
+# Bail out early if on a non-OpenRC system:
+if [ ! -d /run/openrc ]; then
+ eerror "$0 should only be used on OpenRC systems"
+fi
+
+. /lib/rc/sh/functions.sh
+
+export RC_SVCNAME=display-manager
+EXEC="$(get_options service)"
+NAME="$(get_options name)"
+PIDFILE="$(get_options pidfile)"
+START_STOP_ARGS="$(get_options start_stop_args)"
+
+start-stop-daemon --start --exec "${EXEC}" \
+"${NAME:+--name}" "${NAME}" "${PIDFILE:+--pidfile}" "${PIDFILE}" ${START_STOP_ARGS} || \
+eerror "ERROR: could not start the Display Manager"
+
+# vim:ts=4
diff --git a/gui-libs/display-manager-init/files/xdm.initd b/gui-libs/display-manager-init/files/xdm.initd
new file mode 100644
index 000000000000..2fce43b0f47f
--- /dev/null
+++ b/gui-libs/display-manager-init/files/xdm.initd
@@ -0,0 +1,13 @@
+#!/sbin/openrc-run
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License, v2
+
+depend() {
+ need display-manager
+}
+
+start() {
+ return
+}
+
+# vim: set ts=4 :
diff --git a/gui-libs/display-manager-init/metadata.xml b/gui-libs/display-manager-init/metadata.xml
new file mode 100644
index 000000000000..7a7bbf810544
--- /dev/null
+++ b/gui-libs/display-manager-init/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>x11@gentoo.org</email>
+ <name>X11</name>
+ </maintainer>
+</pkgmetadata>