summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2021-02-26 19:10:28 +0000
committerPiotr Karbowski <slashbeast@gentoo.org>2021-02-26 20:23:54 +0100
commitda4634e4944e2aace9f850a298cd64e351b6dcfb (patch)
tree458bef6078e389fb876e7dcfbde742218fdfce53 /gui-libs
parentapp-admin/xkcdpass: fix up manpage a bit (diff)
downloadgentoo-da4634e4944e2aace9f850a298cd64e351b6dcfb.tar.gz
gentoo-da4634e4944e2aace9f850a298cd64e351b6dcfb.tar.bz2
gentoo-da4634e4944e2aace9f850a298cd64e351b6dcfb.zip
gui-libs/display-manager-init: fix quotes
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/display-manager-init/display-manager-init-1.0-r3.ebuild54
-rw-r--r--gui-libs/display-manager-init/files/startDM-r129
2 files changed, 83 insertions, 0 deletions
diff --git a/gui-libs/display-manager-init/display-manager-init-1.0-r3.ebuild b/gui-libs/display-manager-init/display-manager-init-1.0-r3.ebuild
new file mode 100644
index 000000000000..1a18f3f2feb3
--- /dev/null
+++ b/gui-libs/display-manager-init/display-manager-init-1.0-r3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="RC init files for starting display and login managers"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:X11"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 sparc ~x86 ~amd64-linux ~x86-linux"
+
+S="${WORKDIR}"
+
+RDEPEND="
+ sys-apps/gentoo-functions
+ !<=sys-apps/sysvinit-2.98
+ !<=x11-apps/xinit-1.4.1
+ !<=x11-base/xorg-server-1.20.10
+ !=x11-base/xorg-server-1.20.10-r2
+"
+
+src_install() {
+ newinitd "${FILESDIR}"/display-manager-setup.initd display-manager-setup
+ newinitd "${FILESDIR}"/display-manager.initd-r1 display-manager
+ newinitd "${FILESDIR}"/xdm.initd xdm
+ newconfd "${FILESDIR}"/display-manager.confd display-manager
+ newbin "${FILESDIR}"/startDM-r1 startDM
+ # backwards compatibility
+ dosym "${ESYSROOT}"/usr/bin/startDM /etc/X11/startDM.sh
+}
+
+pkg_preinst() {
+ if [[ ${REPLACING_VERSIONS} == "" && -f "${EROOT}"/etc/conf.d/xdm && ! -f "${EROOT}"/etc/conf.d/display-manager ]]; then
+ cp -a "${EROOT}"/etc/conf.d/{xdm,display-manager} || die
+ fi
+ local rlevel using_xdm
+ using_xdm=no
+ for rlevel in boot default sysinit; do
+ if [[ -e "${EROOT}"/etc/runlevels/${rlevel}/xdm ]]; then
+ using_xdm=yes
+ fi
+ done
+ if [[ "${using_xdm}" = "yes" ]]; then
+ ewarn "The 'xdm' service has been replaced by new 'display-manager'"
+ ewarn "service, please switch now:"
+ ewarn
+ ewarn " # rc-update del xdm default"
+ ewarn " # rc-update add display-manager default"
+ ewarn
+ ewarn "Remember to run etc-update or dispatch-conf to update the"
+ ewarn "config protected service files."
+ fi
+}
diff --git a/gui-libs/display-manager-init/files/startDM-r1 b/gui-libs/display-manager-init/files/startDM-r1
new file mode 100644
index 000000000000..b23344bbdcc7
--- /dev/null
+++ b/gui-libs/display-manager-init/files/startDM-r1
@@ -0,0 +1,29 @@
+#!/bin/sh
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License, v2
+
+# We need to source /etc/profile.env for stuff like $LANG to work
+# bug #10190.
+. /etc/profile.env
+
+# need eerror
+. /lib/gentoo/functions.sh
+
+# Bail out early if on a non-OpenRC system:
+if [ ! -d /run/openrc ]; then
+ eerror "$0 should only be used on OpenRC systems"
+fi
+
+. /lib/rc/sh/functions.sh
+
+export RC_SVCNAME=display-manager
+EXEC="$(get_options service)"
+NAME="$(get_options name)"
+PIDFILE="$(get_options pidfile)"
+START_STOP_ARGS="$(get_options start_stop_args)"
+
+start-stop-daemon --start --exec "${EXEC}" \
+${NAME:+--name} ${NAME} ${PIDFILE:+--pidfile} ${PIDFILE} ${START_STOP_ARGS} || \
+eerror "ERROR: could not start the Display Manager"
+
+# vim:ts=4