summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-06-20 12:12:25 -0700
committerMatt Turner <mattst88@gentoo.org>2021-06-20 12:20:58 -0700
commite412e3410e1bdae75756ffc48d06dd1d3035d8f0 (patch)
treef4d6032c338b5aaa1a7e7ba231f0fcaf7a9b4861 /gui-libs
parentgnome-extra/office-runner: Version bump to 1.0.3 (diff)
downloadgentoo-e412e3410e1bdae75756ffc48d06dd1d3035d8f0.tar.gz
gentoo-e412e3410e1bdae75756ffc48d06dd1d3035d8f0.tar.bz2
gentoo-e412e3410e1bdae75756ffc48d06dd1d3035d8f0.zip
gui-libs/libwpe: Version bump to 1.10.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/libwpe/Manifest1
-rw-r--r--gui-libs/libwpe/libwpe-1.10.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/gui-libs/libwpe/Manifest b/gui-libs/libwpe/Manifest
index 48f9dd52c48b..b6220a9b60d3 100644
--- a/gui-libs/libwpe/Manifest
+++ b/gui-libs/libwpe/Manifest
@@ -1 +1,2 @@
DIST libwpe-1.10.0.tar.xz 52004 BLAKE2B 3088cb103b99ab626a74c37910d91fe8abdb07d14d0846bd202716fa1a7d8087e4095e65977e25d9a6f2b97bdfcef664f3872abd8de447ffe3e841a613ebc116 SHA512 b5634dd71cca70eb960f3c045ad109346ab6ce6b01aa8c8bc8f326d232eb16ac1600757896a4b99720af3c77084351ea4f69e2e2c81b9c32cc8bc12a5c66ba3c
+DIST libwpe-1.10.1.tar.xz 51984 BLAKE2B 8afb81e85d134a525a9f7cf0156632ea72a72ab94fcb06c411a11d5304b510cb711a1f2f948cb448bf1ac54c4734cce7a2eaa1ca34c2207c6155d4ab5c350139 SHA512 be1f366ae0d23326ceaab0fe4cdbaea4b50ab822c0e9e7315120fa665113d5eea43f5a23c8e5068f041322d3139cd4de75cfb0f03613cb40586fece1467afbca
diff --git a/gui-libs/libwpe/libwpe-1.10.1.ebuild b/gui-libs/libwpe/libwpe-1.10.1.ebuild
new file mode 100644
index 000000000000..812b9f6d8d15
--- /dev/null
+++ b/gui-libs/libwpe/libwpe-1.10.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Platform-agnostic interfaces for WPE WebKit"
+HOMEPAGE="https://wpewebkit.org/"
+SRC_URI="https://wpewebkit.org/releases/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="1.0"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ media-libs/mesa[egl]
+ x11-libs/libxkbcommon
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dbuild-docs=false # hotdoc not packaged
+ )
+ meson_src_configure
+}